Siri Search not working - cache issue? any fixes

UGH. I’m having the same issue on phone. Not looking forward to the re-install process… thanks all for the tips and paving this road already!

1 Like

FYI I decided to wait it out for an update. Applying today’s iOS update (finally!) seems to have fixed the issue on my XS Max.

1 Like

Thanks for the heads up @bowline. I can confirm that the most recent update fixed this issue on both my iPhone and iPad. I don’t see anything about it in the changelog, however. I just hope it stays working :crossed_fingers:

Sadly I’m still suffering from this, even after iOS 13.

Maybe 13.1 will help. Otherwise I’ll try the restore-from-backup route and report back.

Just to keep using this thread as my personal log on this problem, the reset-and-restore didn’t fix it. It worked for a little while, but then I started having search failures again in the same day.

However. It’s too early to say, but I think I’ve figured out what’s causing this. I think it’s a problem of performance and demands. I never have any issues on my 11" iPad Pro, while my iPhone XR is the thing that’s failing me. My wife’s XR never has trouble, though. So I did some thinking and looked through the apps feeding Siri’s search. Sure enough, there’s a few in there that have a lot of content; DEVONthink To Go and my mail apps, for instance. I’ve disabled their input into Siri Search results and it seems to be working better so far.

Fingers crossed!

1 Like

I’ve been having this problem again as well. Im going to try removing DEVONthink to see if that helps…

I’ve had better performance in general, but it still fails sometimes.

What device is this happening on for you?

Another observation: search also fails in Settings sometimes. I suspect the problem is related.


Seemed resolved for awhile.

And somehow knows to fail everytime when I am at the front of a line and need to get to an app to pay.

I’m not taking it personally though…

Just got finished with Apple Support via Chat for this issue.

I think it’s fixed!

Turns out all that was necessary was a “Reset all settings” action (Settings → General → Reset). Something must have junked up the search settings in the past, and that issue was carried forward in every new setup because I always restored from a backup.

I’ll report back if it fails again, but it seems wholly solved. Woohoo!