Site-specific browser (SSB) creation tool for Apple Silicon (M1)

I’m trying to find a tool to make a desktop app out of a website which creates a Universal App for the new M1 MacBooks. I’ve tried Fluidapp and Unite, and neither of them creates a Universal app. Flotato hasn’t been updated in over six months. What other options are there?

The Unite website says that support is planned:

M1 support planned for early 2021. Rosetta compatible.

But that’s no solution right now…

“Rosetta compatible” is not the same thing as native support. Unite is already Rosetta compatible, but that isn’t what I’m looking for…

As explained by Apple:

“Rosetta is a translation process that allows users to run apps that contain x86_64 instructions on Apple silicon. Rosetta is meant to ease the transition to Apple silicon, giving you time to create a universal binary for your app. It is not a substitute for creating a native version of your app.”

Would you clarify what you mean by Universal App?

A universal app runs natively on Apple Silicon, making use of the speed and energy efficiency of that chip. A Rosetta app runs in an emulator mode and is therefore slower and less efficient.

But would/do you notice?

Apps compiled for Intel run faster in translation on the M1 than they do on actual Intel CPUs in MacBook Airs and most MacBook Pros.

Source:

Yes, it can be noticeable, especially in terms of energy use and the responsiveness of a web browser. Since the web browser is something one tends to have open all day, it can make a major difference.

Looking into this some more I found that the makers of Unite also make Coherence which works on Chrome browsers. Theoretically it should work with Brave which is what I use and which already supports the M1, but it has given me nothing but error messages when trying to use it.

yeah I ran into that as well - Unite has been working fine though, with no perceptible differences in performance from any other browser.