Software Update not seeing latest macOS update

I successfully updated to macOS 12.3.1 on my m1 MacBook Pro 13 inch, but my M1 Mac Mini isn’t seeing the update (“Your Mac is up to date”), and I’ve been trying for a couple days.

Things I’ve tried:

  • Force refresh of Software Update (Command+R)
  • Force quit system preferences and restart Software Update
  • Check for updates via terminal (“softwareupdate -l”), which still shows “No new software available.”

Any suggestions for getting this unstuck? Thanks!

1 Like

I had a similar issue a couple of weeks ago with 12.3.0. The fix for me was to free up space on my SSD. Even with 40GB free on a 512GB drive it wouldn’t show the update.

SilentKnight looks like a pretty cool tool, @karlnyhus. It didn’t show an update for me, unfortunately. I checked my free space, @ACautionaryTale, and had 200 GB. Ultimately, although a restart yesterday did nothing, I tried it again today, and then the update showed up. I did have to force quit ChronoSync, which was running an update and seemed to have hung, so maybe that was interfering with something.

1 Like

I had a small battle with my MacBook Pro to get 12.3.1 installed.

The update was or was not available — it changed about every 10-15 seconds — then when it was and I said Restart now, it did nothing, several times in a row. Then as I was wondering what was happening, it suddenly said “Restart now?” in a notification and I said yes. But it didn’t. So I clicked Restart now, which it didn’t. Then the notification appeared again and I said yes again. This time it restarted, but did not install the update.

Repeat all that again until it did restart a second time and then it installed the update.

Interesting, because the exact same thing happened to me after I posted here about the update finally showing up. I had trouble restarting, and the first time it didn’t install the update.

1 Like

Back in the day I used to wait until I could find the stand-alone updater before I’d start the update process. That hasn’t been an issue for me and I’ve been using Apple’s update service for a few years now.

But if something gets stuck, or one of the caching servers has an issue, you can go to and find the link to the full version on Apple’s servers. That might have helped in this case.

Thank you. I read somewhere that with the new Mac security architecture, the combo updates aren’t available any longer. I did try a link from Apple’s servers (maybe the same one as the link), and the download was over 12 GB and was the full Monterey installer. The link for my model is 13.9 GB, so I suspect that might be the full Monterey installer, too, although I haven’t downloaded it to see.