Solution for "Tags…" keyboard shortcuts not working in Mojave Finder

I had a keyboard shortcut for calling the pop-up window for assigning tags in Finder, but it stopped working in Mojave. Seems to be a crazy bug: Apple pre-populated the “Favorites” window with the (worthless) tags “Green”, “Red”, etc. Once you empty out the Favorites box, the keyboard shortcut becomes available again.

Here’s the link to the Apple forum explanation, with a screenshot

This is episode #213 in the saga of Apple demonstrating their unprecedented level of cluelessness with regard to tagging…

1 Like

UPDATE: On a fresh, nuke-and-pave install of Catalina last weekend, I once again ran into the same problem trying to set up a keyboard shortcut (⌘⌥T) for in System Preferences > Keyboard > Shortcuts > App Shortcuts (see screenshot at bottom; this is one of the few keyboard shortcuts that I can’t set with Keyboard Maestro).

To repeat and clarify the solution (that I rediscovered only once I search the MPU forums and found my own post :man_facepalming: ):

Go to Finder > Preferences > Tags and drag each of the plain-color Tags out of the “Favorites” box (you get the familiar puff of smoke as they disappear). Once empty, the keyboard shortcut will work again in Finder.

BTW: here is how to set the tag-in-Finder shortcut (note that to get the ellipses you need to use ⌥; (not three periods):

Just curious, how are you using tags?

Part of my explanation is here, in an earlier MPU posting..

Here’s another twist:
On the evening before a day full of meetings, I tag all the support files that I might need with the tag “0today” (with a leading zero). In addition, it’s possible to tag a folder, which gives me a shortcut to stuff I’ve already grouped together. I like tagged folders because only two items (folders) show up when I tap on my “0today” tag on the iPad, and then I can drill down on each.

Hello - I have tried and tried this - and it still doesnt work. I have no clue why my Tags shortcut is not working, and it’s really affecting my workflow. Any other suggestions?

Routinely my shortcut stops working. In the past I’ve tried all sorts of troubleshooting; nothing has worked to solve my problem.

If I restart the Mac, it works again. If I kill the Finder process, it works again. (In terminal, type “killall Finder” Warning! I have no idea if this is a dangerous thing to do.)

It is not dangerous, at least with respect to Finder.