Solved: Apple Watch apps not recognising iPhone counterparts

I’m trying to open a couple apps on my Apple Watch - 2Do and Bear - but I’m encountering the same error when opening both of them:

  • When I try to open the Apple Watch app from the App Store (on the Watch), I get the message:
    • Requires iPhone Please launch “<app_name>” on iPhone to complete set up.”
  • When I try to open the Apple Watch app from the app menu, I get the message:
    • <app_name> Requires iPhone App To use this app on your Apple Watch, the iPhone app for <app_name> needs to be installed on <phone_name>”

For the life of me, I can’t figure out how on earth to convince my Apple Watch that these apps are already installed on my iPhone and appropriately set up. I’ve uninstalled and reinstalled the apps from both devices, and restarted both devices.

I’m running iOS 13.1.3 and watchOS 6.0.1 (both latest versions). I’m running the free version of both apps, but reading the documentation for both apps suggests that they can be used with the Apple Watch without paying for the pro versions.

Has anyone encountered the same issue and found a solution?

Just a long shot. Did you try a hard reset on both the iPhone and Watch? I have found my watch sometimes is feeling the blues and a hard reset (hold both the crown and side button in until the apple logo appears) seems to do the trick.

1 Like

Bingo. Hard resetting the iPhone worked. (Tried the Apple Watch first, which didn’t!)

1 Like