SOLVED Is Pages Autosave Working for You in Ventura?

Autosave does not seem to be working in Pages in Ventura. Pages does ask me to save before exiting the program but according to Apple’s support site, Pages autosaves changes after the initial save. This is not working for me.

Can someone verify if Pages is autosaving your work?

If this is a bug, I’ll report it.
Thanks!

I just tried it. Opened a document I had already saved. Added text and closed it. Didn’t do any manual saves. It autosaved it. So it is working for me.

1 Like

@Leeabe51 Thanks. It doesn’t seem to be working for me. I’ll try a few more times. Thanks again, I appreciate it!

1 Like

I was wondering if there was a way to turn off autosave in Pages, but it doesn’t appear you can. I wonder if you could be having a problem with iCloud acting up? Are Numbers/Keynote autosaving?

Is the file you’re editing on iCloud?

@Leeabe51 @nationalinterest Yes, Pages, Keynote, and Numbers in iCloud. Numbers is autosaving but Keynote and Pages are not. Weird. Below are screenshots of a test in Pages I did.

Screenshot 2022-11-08 at 6.15.43 PM

1 Like

After an hour with tech support, we discovered the problem. I needed to deselect the setting shown below. According to the Pages senior support engineer, this is something that needs to be addressed by engineering in future updates. I assume this should be set to “off” as a default. I should point out that I did a clean install when Ventura was released.

2 Likes