SOLVED: Thumbnails not generated for WEBP files

Hello all,

In Finder on my new Mac Studio, thumbnails are not being displayed for WEBP images in a folder. QuickLook using the Space-key will display the image correctly (as well as in the Gallery-view) but all image files are just having the generic icon in the list and grid views.

On my older iMac (also on Monterey 12.4) the same file type is rendering correctly in the grid view. Is this a setting that I have failed to activate on the Mac Studio machine, or is it a bug perhaps?



I remember an article some years (maybe 2, or even more?) ago, that WebP is not working with Preview but is visible on Quicklook.
It seems, that this has not changed under all circumstances!?

Maybe a “Google vs. Apple” Problem…

Thanks Ulli, but according to Wikipedia, WebP support was added in Big Sur. Also, as it works on my iMac running the same OS-version, I find it curious…

According what I found about WebP, and how I read the Wikipedia article about it, WebP Support was only added to Safari starting from iOS14 and BigSur. And this was done by adding it to WebKit by Google.
That does not mean, that the system itself is supporting it 100%

1 Like

WebP images are displaying properly on my MacStudio. Thumbnails icons, QuickLook, and Preview.

I don’t think there’s a setting that would relate to this. I wonder if those images are somehow damaged or use a different compression/encoding scheme — there have been a few versions of WebP since it was introduced.

Does your older iMac display thumbnails for those same files?

Yes, the 2017 iMac displays the correct thumbnails and the Mac Studio displays the files when opened individually in both Preview and Quick Look, but not the thumbnails.

I didn’t think there was a setting either, but you never know…

Weird eh?

I found a hint, that QuickLook might also be responsible for the thumbnails in Finder.
Maybe it is worth a try, to empty the cache of QuickLook?

I just used Graphic Converter to save a JPEG as a WebP image and like @margaretamartin the image shows correct as thumbnail, via quicklook, and with Preview on my Mac Studio.

But as a hobby photographer I have a number of image processing applications install, so perhaps one (or more) of those are providing support. I know I have two applications that provide support for specialized image formats, OsiriX Lite for DICOM (medical) images and Observatory for FITS (astronomical) images.

I hope you figure it out.

1 Like

Thanks again Ulli!

It was worth trying, but unfortunately did not seem to solve the issue. Guess I’ll just wait for 12.5 to drop and see if anything changes then.

I just went through this issue yesterday where none of the thumbnails were showing. This MacRumors article cleared it up. Give it a try.

1 Like

Thanks, that was it!

Almost scary to see the icon display in a folder just snap into view in way less than a second after I re-launched Finder.

All good now!


You might want to move this topic to #tech-support and mark it as solved instead of just putting “SOLVED” in the title.

1 Like

LOL glad to pass along the information. It was driving me bonkers not seeing the preview. Cheers!

1 Like