SOLVED: Ventura - Can't empty trash!

So far everything has worked fine w/ Ventura, but I just discovered that I can’t empty my trash. I can open it and manually “Delete immediately” but I can’t right-click the trash can and select Delete. I mean, I do that, but nothing happens, no error messages, no confirmation, nada.

1 Like

This is working fine for me on Intel 27" iMac. Are you getting the message “are you sure you want to permanently delete…”?

I have the same problem…

MB Air M1 -

As I said in my post, “nothing happens, no error messages, no confirmation, nada.”

FYI - 13.0.1 update fixes this

This happens to me randomly on Monterey.

Curious. Apparently the problem was resolved with the 13.0.1 update, but I’m having it with 13.1. Can’t empty the trash. Also, is trash in the finder now TrashFolder? A search for “Trash,” hoping to find and manually empty, and I come up with two TrashFolder options, both in Library/CoreData/ExternalRecords/ . . . Each of them has a subdirectory of _records that appears empty. (The trash folder is no longer in the sidebar or I wouldn’t be trying a Spotlight or Houdahspot search to locate it.)

Clues?? Thanks in advance.

(MacBook M1 2020)

Okay, I’ve at least accessed the folder (with the “open” option below “empty trash,” duh, I’d never had to use that before). And could empty from there. This is an adequate workaround. But the failure of the usual “empty trash” is still mysterious.