Static IP Address for iPad

I have an IP address reserved on our network as The iPad connects as I need it to be in 172.16.14.xx in order to work with some network devices.

I tried manually setting up the iPad with the desired IP address, correct submask, and router but with no connections.

I also tried to add our DNS manually: school.pvt.k12.xx.xx

But it doesn’t work. Hard and soft resets have been tried.

Is there a way for me to make the iPad find and use the IP address reserved for it?


  1. Select the WiFi Connection
  2. Tap the i to the right
  3. Confiture iP > change to Manual
  4. IP address:
  5. Subnet: (or copy what it gave to you while in automatic mode)
  6. Router: (or copy what it gave to you while in automatic mode)
  7. DNS: and

This should do it.
You might have to power cycle the wifi on your iPhone to make it work.
Alternatively the network admin can assign a static IP address to you.

The scalable/supportable way to have a fixed IP address is to have a DHCP reserved address configured for you by network administrator.

They will need the physical mac (media access control) not “Apple Mac” address of your device and input into their DHCP server configuration.

With a DHCP reserved address, your iPad with work properly on both that network and any other public Wi-Fi network you may use occasionally.

With a manual fully static address (which sounds like what you have tried), you need the exact subnet mask and router address to manually configure yourself. Your network might be using ‘supernetting’ or CIDR routing so the default /24 mask of is probably not correct.

If you use a fully static IP, you must remember to delete it when using another Wi-Fi network and then re-set it back when returning to your primary network - thus a server-controlled DCHP reserved address is a much better “set it and forget it” solution.

Also, you didn’t say if you were on a private isolated network or a network that has Internet connectivity.

For DNS settings, the easiest way to manually configure them is to use the absolute dotted.decimal notation (such as which avoids a potential infinite DNS-lookup failure. and are the global free Google DNS servers. Ignoring security or privacy issues, when having trouble getting connected to a network, manually setting DNS to a well-known public DNS server eliminates one of the potential issues. Once working, you can substitute your own/local DNS servers if desired.


@DJO you seem to be dealing with to subnet here so make sure you don’t have a double NAT and that you are actually connecting to to the right subnet. For example, if you have a modem/router which has the adresse and have an other router to like an Orbi or other router to give wireless access which is also used as a router and not in Bridge mode. The second router is set to 172.16.10.xx which will give adresse in that range and will NOT be able to communicate with devices on the 172.16.14.xx range. So you need to put the second router in Bridge mode so it is just extending the network but is managed by your router.
This, of corse, is if you have two router. If not, then I don’t know:-(

Thank you for the time you all took to lend a hand. All of your advice was helpful and I was able to rectify the situation. I’m a teacher in a small private school who was tapped on the shoulder and enticed with a significant raise to do tech administration. I’ve learned a great deal with advice from people like you.