Synology Drive - deleted files reappear

This question is getting no traction on the Synology forum. Thought I’d ask the fine folk here if they have any ideas.

I just painstakingly deleted several thousand files on my iMac Pro. Now Drive (2.0.0-11050) is putting them right back.
Sync Mode is set for two-way sync.
Default action when relinked is set to Locally deleted files will be removed from your NAS
How can I stop this from happening or fix it?

Perhaps you have the recycle bin enabled ?

have you tried deleting them from a web browser logged in your Synology with FileSation or Drive? I know it’s not the same, but maybe it would work.

1 Like

I did, but have since turned it off.
I haven’t un-paused the client on that computer yet. We’ll see how it goes.

I had an issue with this as well, and I found that I had accidentally set up Cloud Sync task sync direction to Bidirectional and therefore when I deleted a file, when Cloud sync next synced it would re-add the file.

So make sure if you use Cloud Sync you are using Upload local changes only.


I need bidirectional though.
I use it to sync between my iMac Pro and my MacBook Pro.
If I delete on the iMac, it should propagate to the Synology, then to the MacBook, and vice versa.
It works most of the time, but sometimes goes into stupid mode.

Cloud Sync is an application used for syncing to a third party “Cloud” provider. I use it for a subset of shares to backup to BackBlaze B2.

The bidirectional sync I was talking about was inside of a cloud sync task to backup to back blaze, the bidirectional sync that Synology Drive offers would still correctly sync Mac to Synology to Mac, and vice versa. I now assume from this mis-communication you don’t use Cloud Sync at all.

Possibly reach out to Synology, but a better bet would be to use SynoForum which is a better forum than the one from Synology. It also has some highly skilled and willing to help Synology users. Every issue or question I’ve had has been answered on that forum.

1 Like

It completely didn’t register that you said “Cloud” too!

Thanks for the link @joshsullivan, the Synology forum is mostly crickets.

1 Like

I have a very similar situation like yours (not not MacOS). nasA is sync with nasB and nasC. when I delete a particular sub folder (folder A) from any of the nasA/B/C, it will reappeared. Even thought the setting is locally deleted files will not be fetch from server. THIS HAPPEN ONLY TO THIS PARTICULAR SUB FOLDER (Folder A) AND NOT OTHERS.

Finally, I disconnect all the 3 nas from the internet, delete the problematic sub folder from the three Nas before I connect them back to the internet. The problem is finally solved.

I inform Synology support that there could be a bug in the File Station. Support insisted that I did not set the sync correctly, which I could not agree. Because it only happen to a particular sub folder and not other folders. They would like to access my nas to check but due to confidentiality of the data, I could not allow them to do it.

1 Like