Synology NAS Configuration Problem -- SOLVED

Synology DS218+ (I’ll call it NAS) has been working fine for over a year connected to my home network (192.168.1.x) and not available outside my home.

A couple days ago, I was prompted to update to the latest DSM. I did. Afterwards, NAS no longer appears on my network no in the SynologyAssistant.

If I direct connect ethernet cable from computer to NAS, I can see the device. Drives and data are healthy, but I can’t change/apply settings to IP Configuration. I’ve tried setting it to DHCP, so it will take an IP number from the router. I’ve tried setting a static number on my 192 network. Neither seems to stick. Of course, when I apply changes to IP, I lose my direct connection, have to restart NAS, but it never seems to save the 192.

I would appreciate any advice?


According to Synology Support, something about the updated DSM affected my device’s network configuration. Even though I could direct connect to the NAS, I was unable to reset the network settings.

Specifically, even though my NAS was configured to use DHCP to pull an IP address from my router, it was not working.

Per Synology’s instructions, I used a paperclip to reset the NAS. This “first-level reset” erases the admin password and resets the network configuration. After that, I rebooted and the NAS grabbed an IP number from my router. I then reset my admin password.

The first-level reset does not affect the volumes/data on the NAS. So, it was a bit scary, but no loss.

Thanks for all the ideas and support.


Why? Do you get an error, or do the settings simply not stick?

Could it be there’s a conflict with another device on your network?

Just throwing it out: did you try “” in a browser window?

It’s possilble there’s a step in this help document, after you direct-connect again, that you might have missed:

The way I read this, Synology wants you to run the initial “setup” wizard again rather that try and fix the connection piecemeal.

If you read the initial post carefully you can see that he can access the NAS when he connects directly. The whole procedure you mention is thus not applicable.

After just a DSM update you definitely shouldn’t run the setup wizard again.

@KirkS: you could also try to look at (and if needed, change) the network settings on the Synology via SSH if you’re coonected to it directly.

Well, from my link, following point 2:

Which is followed by point 3:

The “setup” referred to here is for the connection, not for the whole of DSM, which again the linked example makes clear. My thinking is that re-running the connection set up may make changes that are more thorough or behind the scenes than just correcting the IP address.

Nowhere in the link is there mention of setting up the DSM from scratch.

FYI in the latest episode of the 9to5Mac Happy Hour podcast at around 35:00 Benjamin Mayo discusses a Synology problem he’s had after updating Catalina: if he goes into Finder, clicks Synology on the left sidebar and then clicks on one of the shared folders, it never joins, saying, ‘Cannot Connect, This Item is Missing.’ But if he goes to the Finder’s menubar, click Go then Connect To Server, pick Synology then select the same shared folder “it connects every single time.” So perhaps you could try connecting from the Go menu?

Start by restarting the router.
The reboot the NAS

Fantastic. I saw in reddit other people having DS218+s amnd problems with the latest DSM update, so hopefully the solution for other people is also fairly simple, without data loss.