Synology Photo Station won’t play movies from IPhone XR

I took over 1000 pictures and movies (mostly pictures) on my iPhone e XR when we were in Spain a few years ago, I’ve just recently uploaded them onto my DS1520+ in order to view them in Photo Station.

None of the movies will play in photo station but work fine on my Macmini/Big Sur. The pictures are displayed just fine.

I’ve been working with Synology support for a few weeks but they’ve given up.

I’m curious if any of you have had an issue like this.

The ones that have been uploaded by my wife to Photostation seem to be working fine on our DS220+. They’re .MOV files, but I haven’t checked the codecs. Is it the browser you’re using? I’ve checked on Windows in Chrome so far, but that has seemed to play them.

What’s the extension? If it’s HEVC that’s the iPhone native standard which may not be supported by your NAS. It’s H265 which isn’t widely supported yet.

Mov is the extension.
I’m sure tech support knows that mov are supported.

I’ve tried chrome and safari, both of which should be working- easily.

I solved this issue, but don’t know what caused it in the first place.

  • Shut down photo station

  • Uninstall photo station

  • Copy files from /photo to an external drive

  • Delete /photo

  • Reinstall photo station

  • Copy all files from external drive back to /photo using File Station instead of Photo Station’s web interface.

  • Start photo station

  • Reindex all pix & videos

The movies are now playing in the same web browser.

Tech support wasn’t able to find /fix the issue, so I told them how I made it work.

When I originally uploaded my files in photo station, I used the web interface.
When I did this, photo station only allowed me to upload 105 files, and just ignored the rest,
I suspect some metadata must have gotten corrupted.

When I first did the upload it was the first time using photo station. I fid not know about File station at that time.

I’m a happy camper now. but disappointed with their tech support.