Tech irritation: Fantastical and birthdays

I have searched and do not see this. All of a sudden birthdays are showing up in my fantastical calendar. Not just family birthday–but everyone of my 1600+ FB friends. I have looked at the settings in Facebook, unchecked the birthday calendar in both Apple Calendar and Fantastical on my computer, iPad and iPhone but they’re still showing up. I have also unchecked alerts for birthdays. I promised I googled and looked here and on the FB group The Apple Orchard. TIA.

In the app check Preferences > Alerts

“Fantastical can be set to automatically add alerts to new Timed, All-Day, and Birthday/Anniversary events. Notification types and alert times can be specified for each type.”

(Don’t be afraid to use Google; I found that by searching site:flexibits.com birthdays )

Also check to see if you have CardHop installed as well, which also announces birthday alerts.

1 Like

@bowline–I always appreciate your help but that’s not it either. Sigh. It’s not that I mind seeing friends’ birthdays but I already see those on FB. It creates a lot of clutter on my calendar.

Have you tried unchecking all your calendars, one at a time, to see which one is displaying the birthdays? I haven’t used Fantastical in a few years, but this method has helped me run down problems in my calendar apps.

Thanks. Yes, I have tried this, Wayne G. The calendar for birthdays is uncheck on all devices, both on the native app and Fantastical.

What version fantastical? I’m still on v2 and haven’t upgraded.

You should be able to see which calendar has the FB birthdays. I’m guessing that you logged into your FB account and will need to disable that to prevent the birthdays from showing up.

I’ve resolved it now. I did follow the steps that all have posted. Thanks for your help!

1 Like

I love Fantastical. It is unusable.

I am about to write some kind of script to delete people’s birthdays from my contacts BECAUSE I DON’T WANT BIRTHDAYS APPEARING IN MY CALENDAR.

Yes, my preferences have birthdays checked off. Yet when I look at “All calendars”, my 1000+ contacts have their birthdays placed as events. I don’t even celebrate birthdays.

I’ve looked in Contacts and in Calendar to see what’s happening. This is rendering Fantastical useless for me. Please help.

You should make a calendar set that has everything but contacts/birthdays checked, and use that instead of All Calendars. I only look at All Calendars for troubleshooting.

If you want them to not sync at all, you are going to have to prevent syncing from the source and that will apply on every device and app. For example, to stop birthdays from coming in from Google, you have to visit sync select and uncheck that calendar there, and then Fantastical won’t have the data.

Thanks. I thought I’d need to do that.

Fantastical has no way to disable notification of birthdays even when I uncheck “Birthdays” in the calendar preferences? That sounds like a bug I’ll file with Flexibits.

These seems to be very unwieldy. I love Fantastical, but this is very sloppy.

In this case, the account in question is syncing from iCloud, not Google.

Thanks for the quick, rapid, and informed response. Much appreciated.

That I wish I knew more about. In “automatically add an alert…” I actually have none for all event types, but I still get notified about every calendar event 15 minutes before. I just tested it now and receive the same notification whether the new event says none or has one explicitly added. I don’t understand why, so I’ll be contacting support as well.

I heard back from Fantastical. My alerts were defaults coming from Gmail, which passed its default alerts. Not helpful for the iCloud birthday situation, admittedly, unless those are being set somewhere by iCloud.com.

Thanks for getting back to this.

It is indeed an irritation. I’m thinking of writing an Applescript to take out birth dates from all of my contacts.