The Unarchiver - how to prevent prompting every time?

I use The Unarchiver, and every time I go to extract an archive it asks me for permission to write to the folder. I tried giving it Full Disk Access, and nothing.

I thought there used to be a way to get rid of that behavior, but I’m coming up blank. Does anybody know how to fix the issue?

Or alternatively, is there another archiving program that can handle the common formats (zip, rar, etc.) that y’all would suggest instead?

You might want to try Keka.

https://www.keka.io/en/

I’m happy to pay for an app, but a question quick. Are all of the in-app purchases just donations to the dev? $5 gets me all the functionality?

I believe the version from the website is free and should include all the features. I think I have that one installed, try that one first.

Edit: make sure to read the part about the helper that needs to be installed to set Keka as the default unarchiver in Finder.

Is yours the app store version? There’s a comment here that suggests extracting to your home folder may solve issues with repeated requests further down the directory tree.

Probably the App Store version. I can’t extract this stuff to my home folder - this is all huge archives that live on an external drive.

The request it’s giving though doesn’t seem to be the one from the bug report. I have that preference set, and it knows where I want the extraction when the window pops up - but it keeps acting like it doesn’t have permission to put files into that folder.