Time Machine Problems

Macbook Pro 2021 w/ M1 Monterey 12.4

  • I decided to try using time machine.

  • I reformatted a 2 TB external spinning Drive (APFS)

  • I opened time machine preferences and selected this drive

  • I unchecked back up automatically

  • next I chose menu = back up now

  • I saw that the process started and I left - a few hours later it said it had used about 600 gigs on the drive and it looks like it would finish soon.

  • next morning - Time Machine was still running - it said it was about 11% complete. The Drive showed just a few hundred gigs free.

What? The internal is less than one terabyte - and Time Machine almost filled up 2 TB? what?

  • I let it keep running and a little while later it said it had used up all the free space on the external and was not able to complete the first backup due to insufficient space.

  • also I see that there are NEW Time Machine local snapshots create it since last night - why?

Q: so I thought I did everything correctly however I got the strange results and no time machine backup working. Do you have any suggestions what happened here and how to get Time machine working properly?


  • Computer is set to not go to sleep
  • the internal drive is 2 TB and the spinning external also 2 TB
  • there is less than one terabyte being used on the internal right now – Plenty of free space.
  • I am reasonably sure there is nothing wrong with the external Legacy spinning Drive.

Thanks – Dave

All sounds normal. First backup takes a while.

Sadly, the answer to most Time Machine questions like this is just wait and hope. Especially on the first run.

You can get much more granular about it and fill your days searching and reading, but I don’t think it will be productive.

1 Like

Thanks for the help…

ok - but the issue is that my internal 2TB is less than 1 TB full and the external 2TB filled up completely and was not able to finish initial pass.

Why did that happen?

So I am still in the dark as to why the external filled up 2TB when the source is less than 1TB and never was able to complete the FIRST backup?

  • I will also mention that the day before I had successfully formatted another 1 TB external spinning and new time machine COMPLETED ok (for this same machine) And when I started this 2nd 2TB TM - I told it to keep both. Was that a bad Idea? Should I just have ONLY one TM for this computer?

If I delete everything and start again - what do you suggest to get this working correctly?

There’s no good answer. Something is not working correctly. It’s not simply a matter of selecting the right options.

If the 2TB external drive is a spinning disk I would format it for Mac with a GUID partition and HFS+.

See what happens when you plug it in and select it for Time Machine. An M1 and/or Monterey Mac may have its own ideas about the proper format and make a change. But go with what it wants and see if it works better this time.

Also set up for the first backup to be run on a quiet machine such as when you’re about to go to bed for the night. And once it has started the initial backup, I turn off “Backup Automatically” until the first backup has completed successfully.

1 Like

Ok Thanks - good ideas - I will try:

  • yes - will format spinning as HFS+ guid at first

  • Yes - will run at night when quiet (did this last night)

  • I will let it start automatically - then do as you said = I turn off “Backup Automatically” until the first backup has completed successfully.

  • also I disconnected the other drives prior to running TM and will do this again

Also I found this…

and this

also found this in DU…
aScreen Shot 2022-05-29 at 11.07.39 AM

1 Like

I stopped using Time Machine on my MBP as it takes up too much space and there is nothing locally on the computer that is so critical if I lose it. I can rebuild from fresh if the machine fails for whether reasons.

Generally, storage on Apple machines has become very expensive, hence I try to store data externally

I just tried that - where it begins with auto start - but when I turn odd “Backup Automatically” then the initial backup stopped.

So I guess I will need to START with “Backup Automatically” = OFF and just do a manual start for the first pass - right?

Sure. It has been a while since I had to start a new backup on my Time Capsule, so I would say that you should go with what you have found that works.

I tried to keep it as simple as possible. In fact, I never have “Backup Automatically” turned on as I use the “TimeMachineEditor” app to run Time Capsule backups on a custom schedule that suits my work better than having it run every hour. And I often kick off a manual Time Machine backup when I’ve stored something significant that I want to quickly backup. And I turn TM off while I run my weekly offsite Arq backup. So, you see, there is a lot of flexibility in the way we can use these tools. :slightly_smiling_face:

1 Like

Is it possible that some of the files “on” your internal drive aren’t actually there – they are “in the cloud” files (eg on Dropbox, iCloud or something similar)?

If so, maybe Time Machine is backing up much more than the 1TB that shows as used space.


good thought - thanks

Time Machine Update:

First of all, thank you all for your help getting my issues resolved.

I’m happy to say that this morning I woke up to a working time machine external drive.

I followed your suggestions:

  • start by formatting as HFS+ (pretty sure APFS would work also)
  • Choose Drive and manually start TM
  • let it run until complete. (I had completed this several times before and did not realize until today what was going on):

!!! here’s the deal … !!!

in Monterey 12.4 - the initial first completed pass of Time machine = IS BLANK in the window!

When I looked at the external drive window it was empty even though it said that much of the drive space was used.

So that is why I kept looking at thinking it was broken!

Next I manually ran the NEXT update to TM (and since have turned on ‘back up automatically’) - and now the drive starts filling up with Folders with timestamps.

→ So it seems that the initial back up is NOT presented to the user.

Once again thanks for all the help getting this Time machine issue sorted it out.