TouchID problem

Hey all, I have run into a problem with TouchID and am wondering if anyone has encountered it or has an idea for a solution.

I have an early 2020 (Intel) MacBook Air on macOS 11.1 and have noticed that recently the touch ID has stopped working when trying to wake the machine from sleep or attempting to fill a field using keychain. To try and rectify this I attempted to re-register my fingerprints, however when I tried to re-register the fingerprints by clicking the add fingerprint button in system preferences and inputting my password nothing else occurred. There is to say, there was no interface for a fingerprint reading or any other UI change in the system preferences window. I have tried restarting the machine multiple times and I’m still unable to register any fingerprints whatsoever.

I do plan on calling Apple about this issue tomorrow, and will update this post with any solution that they may have, but I’m wondering if anyone has any ideas in the meantime.

Did you uncheck all four options for “Use Touch ID for:” and then remove the existing fingerprint?

I had this problem last week, and fixed it by:

  1. uncheck all “Use Touch ID” options;
  2. Remove the existing fingerprint;
  3. Shut down;
  4. Launch in Safe mode;
  5. Shut down and relaunch;
  6. Register a new fingerprint with “Add Fingerprint”
  7. Check all “Use Touch ID” options

In steps 6 and 7 there will be at least one request to authenticate with password.

At least, these are the steps I had to follow. Doing the Safe mode boot might have been unneeded.

I haven’t tried booting into safe mode yet, will give that a shot!

So I went through Safe mode as @quorm suggested and it seemed like it was working but the preferences still wouldn’t save when I left the Preferences window. The solution that finally worked for me was a hard reset (holding the power button down for 10 seconds then rebooting after a second or two). After doing this I was able to register multiple fingerprints and adjust the options below that as well. I got this idea after looking through this developer thread. If this doesn’t work then the next step is a good ol’ SMC reset.

Hope this helps someone!