Trouble with Synology since upgrading to Mojave

macos
#1

Hey everyone can you help me out?

I’ve got a Synology NAS that I use for general storage, Plex, and OTA time machines for my MBP and my wife’s MBA. Ever since I upgraded to Mojave, my MBP can’t connect via smb and and my time machine won’t back up. I haven’t upgraded my wife’s though and all is well for her.

I’ve searched a ton and looked all over on forums and haven’t found anyone else with this problem. Anyone else having this problem or aware of an smb issue in Mojave they might be causing this?

I’ve tried tried reaching out to Synology directly, unfortunately, they have been unresponsive.

Thanks in advance!

#2

My machines run Mojave and aren’t having any trouble with file sharing or Time Machine. Plex is still working fine as well. None of the points I’ll mention are ‘known answers’ for your situation but if all else fails these are some things to try/check.

I assume the NAS shows up the finder - if so when you try to mount a shared folder does it just silently time out or is there any error displayed? If your Mac has a user ID different than yours have you tried logging in as the other user and mounting a share? If you and your wife have different user IDs on the Synology have you tried doing a ‘connect as’ and using her credentials instead of years? Has the NAS been rebooted since this started?

Are you running the latest DSM on the Synology? Do you have AFP enabled as well as SMB (if so turn it off)? You could try changing the minimum level of SMB the Synology will accept (e.g. V2 and V3 but not V1).

You may also want to ask about this on Synoloy’s DSM customer forum.

#3

I’ve occasionally had flakey mounting of my Synology on my MBP (from macOS 10.12 thru 10.14.x). I also do not use Synology for Time Machine any more since twice I’ve had TM corruption on the device.

For reliable mounting, I include the Synology volume among the Login items for my user account and on my wife’s machine.

1 Like
#4

Does the mac give you any kind of error message?

#5

I’ve also had fairly flaky SMB/AFP connections to my Synology from MacOS (Mojave and previous variants). I’m now using Automounter by PixelEyes which is doing a great job at mounting, monitoring and re-mounting as necessary.

#6

The NAS is not available in finder all. When I tried to connect it just says that the server can’t be found. As far as my machine is concerned, the Synology isn’t there.

I have also reached out on the DSM forum and they have been no help either.

#7

can you ping the ip address of the NAS from the mac?

And have you checked on the synology if the mac’s ip address is in the blocked list? (can happen on new installs with too many attempts to log in)

#8

I have similar problems on a regular basis. Often the NAS doesn’t show up in the finder after my mac wakes up… Sometimes it does but shows up with all lower can name (e.g. If the name of the device is NAS1 it shows up as nas1) and won’t connect. Sometimes restarting finder works and sometimes not. Sometimes turning-off/on wifi works and sometimes not. Something that usually works is go to server and connecting by IP address… But I don’t really like that solutioin.

#9

I have solved this by using the mountain app to mount/unmount network drives.
Makes it very simple for me now.

https://appgineers.de/mountain/