Trying to stop Keyboard Print Screen from automatically taking a screen shot

I tried asking this on the Karabiner forum and no dice.

I have a Logitech Ergo K860 and mostly its an amazing keyboard. It has but one fault. I keep on hitting the Print Screen button, because its above the backspace. This automatically takes a screenshot.

I’ve tried setting it to “none” in the Logitech Options app and MacOS still takes screen shots.

I’ve tried remapping in in Keyboard Karabiner:

and it still takes screenshots.

My guesses:

  • This is being done at an os level deeper than logitech or Keyboard Karabiner see - unlikely
  • print_screen is the wrong key code If that is the case is there a keyboard monitor that allows me to see which key is being triggered for PrintScreen.

Is there a way in MacOS? Karabiner? Keyboard Maestro? … to block this from triggering?

Lost deep in MacOS.

1 Like

Have you tried remapping to backspace?

I also use this keyboard. If you have Logi Options installed you can configure the keyboard settings directly from there, including remapping the print screen key.

1 Like

So a funny thing. That was the first thing I tried and retried. It seems to work for a while and then stop all of a sudden.

I hit that key ALL day long - dumb design. Apart from that i totally love this keyboard. Thanks for the suggested fix gang!

1 Like

FWIW I’ve given up on karabiner for a solution. Instead I get Hazel to delete the screenshots after a week.

I was also trying to find a solution to this issue but found nothing on the net. Then used Karabiner Viewer to identify what is it triggering. Found it was Cmd-Shift-3. Disabled that shortcut from " Settings>Keyboard>Keyboard Shortcuts" as I do not use that shortcut for taking my screenshots. I prefer Cmd-Shift-4. And Voila. PrintScreen on K860 is a useless key now :smiley:

1 Like

Wow. Just wow. I would never have looked there. In seconds a problem that has dogged me for a year goes away. This tidbit of information is going to stored (no enshrined) in my Obsidian vault.