Ulysses having issues with icloud sync...15-20 groups with sheets not downloading

I’m having issues with Ulysses sync again on my MacBook Pro. Changes that I make on my other devices aren’t syncing to my MacBook. All other apps on my MacBook sync with no problem which tells me that this is a Ulysses problem and not iCloud. This isn’t the first time I’ve had this problem on my MacBook.

Ulysses support has been no help with this issue. I’ve found that disabling and enabling iCloud sync in Ulysses settings or starting a new sheet forces a sync. It’s a work around but doesn’t give me feeling of confidence with Ulysses sync.

Now I’m sorry that I just renewed my subscription. I’m going to follow the lead of @tjluoma and move to Bear.

1 Like

A major upgrade Ulysses 15 is around the corner. (Don’t know how big/long the curve is.) Even though, I have had no problems with sync, maybe this will clear up the difficulties.you have experienced.

Sorry to hear that. You might find this interesting reading.

Thank you for the link. I’ve contacted Ulysses support with this issue in the past. They were unable to resolve it for me so regardless of whether the issue is Ulysses or iCloud I can’t trust the syncing of my Ulysses sheets.

I’m still using Ulysses. But I’ve been giving a long, hard, awkward stare at IA Writer over the past few days.

  1. Partially because I have The Fear now.
  2. Partially because IA matches the features in Ulysses that I use, and I don’t use many of the features in Ulysses.
  3. Partially because I could then index those files in Devonthink, and also use The Archive and 1writer for the same files.
  4. Partially because I already own it and it’s not on a subscription model.
  5. Partially because the blending of folders and tags seems like it combines the best of Ulysses and Bear … and I could stop using Bear as well.

And frankly, I’m worn out from fiddling around with apps. Plain-text might finally allow my soul to rest.


I made the switch from a Ulysses/Bear combo to iA Writer. Since you mention tags specifically I’ll note that one tag-related feature in Bear that iA Writer does not implement is the ability to nest tags (a “work” tag with separate tags within it for individual projects, for instance). That’s one that I really miss.

1 Like

I, too, am having sync problems with Ulysses.

First nine months, all was fine, but then…

  • I ran into an issue very similar to what @KevinR reported at the top, which is how I came to this page (fixed it with the same “move 'em to a different group” solution he mentioned).

  • Then, another day, sync was ultra-slow and the iCloud icon on Finder was going nuts as if the system were “thrashing around” trying to find stuff. It finally settled down, but was unnerving to watch.

  • Most recently, I got the dreaded red-sheet error where it popped up a conflict warning right in the middle of a writing session. Neither of the two choices it gave me was current, but I took the newest one and figured, ah, well, I’ll just rewrite what I lost — only to open the same sheet up on a different device and find all of the lost stuff still there after all. That one is the weirdest of all, at least so far.

So, at the end of this rant, I do have a question: am I snakebit, or does this behavior and what you other posters mentioned simply mean that there is an inherent, long-standing bug in Ulysses’s file storage model that makes it an unreliable vessel for one’s work? I, like @KevinR, have been giving iA Writer that “long, hard, awkward stare,” and for pretty much the same reasons. I already use iA Writer for blogging, and now am wondering whether to move my fiction work to it from Ulysses, as well. My early tests of doing so have been promising, and the non-proprietary, unobscured file storage is like a breath of fresh air.

Will be very grateful for your collective wisdom on this, my friends and colleagues.

1 Like

I’ve recently made the switch to iA Writer from a combination of Ulysses and Bear. The fact that it stores everything as regular files in iCloud was a factor (as was it’s support of Open in Place on iOS). About two months in and I’m happy with the switch so far.

1 Like

Yes, found your post and the linked one very helpful. Thanks.

1 Like

A little more info…

I sent a question to Ulysses Support asking whether (in essence) I could get around this concern by using the External Folders feature and just having an iCloud Drive folder for Ulysses that the iOS apps would also be able to see. It would be manual and not in the Ulysses Library, but at least it would get around this particular iCloud worry — I thought.

The response was that Ulysses for iOS doesn’t support this so, while it would be visible to Ulysses on the Mac, it wouldn’t be to the iOS app. Specifically, I was told:

In order to achieve cross-synching between those two platforms, you would need to use Dropbox. This limitation is due to the fact that Ulysses for iOS currently doesn’t support any other syncing backends but the one for Dropbox. [sic]

However, I thought the iOS app supports “Open in Place.” Is that not what that means?

Correction/enlightenment welcomed.

This is a follow up to my original post. At the time of my post, I suggested that I was going to move my writing to Bear. In the end, I decided on iA Writer for my writing and Bear for my notes and lists as I have always used it for that. I’ve moved all my writing out of Ulysses and into iA Writer using Dropbox for storage. iA Writer has everything I need. I’m happy with this setup.


I’m having trouble with Ulysses sync too. Documents (sheets) from my Mac sometimes don’t sync over to iOS (I think I’d feel better if sync either did or didn’t work!). I used to think the sync issue was related to figures i had embedded into the files on Mac, but now i have un-synced documents both with and without figures. I’m having a hard time feeling that i can rely on Ulysses to do the job. I’ve contacted Support and their email indicated it was a problem on the iCloud side. Might be true - but i don’t have this problem with other iCloud-attached apps. Ulysses sure gives a pretty interface with which to work - but not at the expense of function. Checking out my options.

In my case, they finally had me send them logs from my Mac and they found that the iCloud setup had become corrupted somehow. I followed their resulting instructions and all has gone well since; that was about a month ago. Have they asked you for that data as well?

Not to pile on here, but Ulysses syncing is not great here either…or at least not immediate. Over the last 30 minutes: in the first 15, no update to my iPad from my Mac writing. Then, full update 15 minutes in and only takes 10 seconds or so now to sync from Mac to iPad. Doesn’t engender great confidence. For grins, I tested Notability sync, which is also on iCloud, and the sync nearly instantaneous among three devices. My subscription just renewed for the year on the 17th. Ugh.

Ulysses continues to have iCloud sync issues

I was looking at Ulysses reviews in the App Store today and noticed several recent reviews with complaints about iCloud sync issues. This is not a new issue as has been discussed here. This has been an ongoing issue for several years. It’s the main reason that I no longer use Ulysses.

I would think that Ulysses would do something to fix this problem. Of course, they always say the problem is with iCloud Drive and not Ulysses. I don’t buy that because lots of other apps use iCloud with no problems. I recently wrote about that here.

Maybe they should spend some of their subscription money on developing a sync backend.

Well FWIW i sync about 1.2 million words in Ulysses and haven’t had any sync issues for several years.

One of my most-used apps - I mostly write on the Mac, edit (occasionally) on iOS. No sync issues here.

As I noted earlier in the thread, my iCloud problems with Ulysses turned out to be due to some weirdness specific to my Mac. However, it’s clear from reading App Store reviews that a number of apps, Ulysses among them, have run into a buzzsaw, iCloud-wise, with iOS 13 and Catalina. (So has iA Writer, apparently, although its team seems to have found ways to mitigate the issues.) There is plenty of blame to go around.

All that said, my Ulysses-specific writing output has dwindled recently for a variety of reasons, and — with my subscription coming to an end before long — I have a decision to make. Last year, I decided to stick with Big U. The jury is out right now.

Not sure if this helps but I created a new group (folder) in Ulysses and moved all the sheets into a new group. I waited for it to sync to my other devices then moved them back into the original folder. That cleared up one folder that was blocking the other folders from syncing that seemed to clear it up.

I suspect it’s more an iCloud issue than an individual app issue. Most of the time, iCloud syncing in Ulysses has worked for me. But once in a blue moon, the iCloud monster rears its ugly head.

1 Like

Hi, also having trouble with unreliable iCloud-Sync. The external-folders-method in iCloud Drive (mentioned by bwintx) seems to be an alternative to the “normal” iCloud-sync. Works for me across 2 Macs, an iPhone and an iPad. But have to test it for some time first, as normal iCloud-Sync also works for days or even weeks at a time. And then comes a day with hiccups…