Unable to communicate with the printer at this time

I have an HP Envy printer which I’ve used without problem for a few months. Today my Macbook Air simply refuses to print to it. They’re connected by WiFi.

I’ve tried rebooting the Mac, rebooting the printer. I’ve deleted the printer from my Mac and reset the printing system. When I go to add the printer again, the Mac sees it quickly and lists it correctly… but then fails when setting it up with the message “Unable to communicate with the printer at this time.”

I can print to the printer from my phone and iPad no problem - all on the same WiFi network.

Any ideas before I throw the Mac out of the office window?

Rebooting the router resolved the issue - the only thing I hadn’t tried. I’ve apologised to my Mac.


I had this with a Mac mini and an HP envy 7830. I think I ended up downloading the HP Smart software. Terrible software but I did mange to fix it. Not sure exactly what I did though.

Also I would throw the printer out - not the Mac :wink:

1 Like

Thanks… resolved by a reboot of the network router… so both the Mac and Printer are safe for now. The HP Smart software is truly awful. Not sure why I need an account to scan a document. :confused:

So they can sneak updates onto your printer and harangue you to buy Instant Ink!


Neither here nor there, but I kinda liked that error message…

Very close to “Miss Otis regrets she’s unable to print today” - which would have been even better.

The reference is a bit dated and I apologize for my silly brain - it does that sometimes.

The answer to 99% of all computer issues is “turn it off and back on again.”

Since the router reboot seems to be a universal cure - we need a giant red on/off toggle switch on the front of them that is easy reach instead of having to reach around and poke for a button or stab with a paperclip. This would definitely be a function vs form issue that I would be willing to embrace.


On the contrary… a giant red toggle on a router would be a sight for sore eyes IMO :laughing: