Unable to erase Samsung T7 (fixed)

I have a Samsung T7 SSD that was used as a boot drive on an old Mac Mini. Replaced the Mini and wanted to use the drive for other purposes. When I try to erase it or remove the existing volumes in Disk Utility it just says it’s erasing and never completes, even after multiple days. It’s formatted APFS with a single container and 2 volumes - system and data. I’ve tried erasing it on different Macs with the same results.

Have you tried erasing the physical device, not the volume.

Yes, it sat there running but never completes. Here’s what I see for hours:

1 Like

Try erasing the T7 device as Mac OS Extended (or ExFAT). If that works then erase it again using APFS or whatever.

Exact same results - ran overnight without completing. I also tried formatting it on an old Windows laptop but it wasn’t recognized. However my Windows skills have severely atrophied since I retired.

1 Like

Sorry, the format as ExFAT/MacOS worked the time or two I had a similar problem. Good luck.

How to do it on Windows (never had to do it myself though):

  1. Launch a new Command Prompt (cmd)
  2. Type the command diskpart
  3. type list disk and note the number of the APFS formatted disk
  4. type select disk X where X is the number noted in step 3
  5. type clean. Now the drive doesn’t have partitions anymore, it’s just an unallocated space.
  6. Go to Disk Management, by right clicking on the start menu button.
  7. Select the unallocated space that corresponds to your drive, right click and Format
1 Like

Thank you so much. This did the job. Formatted it on Windows as ExFat and then erased in on my iMac as APFS. Now it’s clean and usable.