Unable to use file sharing

Fellow Power users!

I have a strange problem that I cannot solve on my own.

A client of mine have one iMac with Catalina and one MacBook Pro with Monterey. He have two hard drives attached to the iMac that he wants to access from the MBP. No problems I say, just start the file sharing! Easy.
It turns out though that it actually IS a big problem. No matter how I try I can’t get file sharing to work on the effing machine!
I have pinpointed the problem down to the iMac, because I can file share between my own MBP and his MBP, and I can also file share from the MBP to the iMac. But not from the iMac.

What happens:
For a starter, I can’t turn file sharing on or off in System Preferences. I have to use the Terminal.
I can see the iMac in the network, and I can connect and enter the correct user credentials. But when I look for files, all folders and/or drives are empty. Doubleclicking on those empty folders gives an error message in Finder like “Can’t open Macintosh HD. An unknown error has occured.”
I have SMB turned on on all machines. I have also tried AFP, with the same result.
Two preference checkboxes in System Preferences > Sharing are light grey and unmodifiable. Those are File Sharing and Remote Login. If I check File Sharing nothing happens, if I check Remote Login it says it’s starting to turn it off, but it never turns off.
As mentioned, I am able to turn on or off File Sharing in Terminal with sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.smbd.plist and that also updates the checkmark in the Sharing pane. Doesn’t help with the file sharing though.

What I have done:
Restarting all involved machines.
Reset PRAM.
Emptying Cache with the help of Shift during startup.
Created a new user.
Deleted all files in /Library/Preferences/SystemConfiguration/
I have reinstalled Catalina, but kept all old settings.

What I suspect:
Since there is no possibility to manage File Sharing with System Preferences I suspect that there must be a damaged preference file somewhere. I don’t know where though. :frowning:
There must be some kind of “Network factory reset”, but the only thing I can find about this is the deletion of files in the SystemConfiguration folder mentioned above.

What I haven’t done:
I haven’t installed a clean, new system. If I can’t solve this any other way, this is the final solution. I prefer to not have to do that though, since it includes a lot of extra work (install new apps, Mail accounts etc etc).
BTW; Catalina is the newest macOS this iMac (27" late 2013) can have.

Any ideas? :grimacing:

My only suggestion is to somehow switch from SMB to AFP or vice versa? You have already made an heroic attempt to solve the problem. I sympathize with your predicament. :upside_down_face:

1 Like

I think the problem is because your user isn’t a “Power User.”
I just created a non-admin user on my box, logged in, and all sharing was disabled.
Try making them an admin and see if that helps.

He is already an Administrator. My test account was also an Admin.

Thanks anyway :+1:

Since things are borked, have you looked at groups from the Terminal to confirm?

 ❯ groups
staff everyone localaccounts _appserverusr admin _appserveradm 
_lpadmin access_bpf com.apple.sharepoint.group.1 
com.apple.sharepoint.group.2 _appstore _lpoperator _developer 
_analyticsusers com.apple.access_ftp com.apple.access_screensharing 
com.apple.access_ssh com.apple.access_remote_ae

Membership in the com.apple.access_* groups allows changing those sharing types.

Thanks John!

That command gives what groups the current user belongs to, right?

I will do that to maybe narrow the problem down.
However, it still doesn’t explain why System Preferences > Sharing is uneditable. :thinking:


If the user is not a member of, e.g., the com.apple.access_ftp group, they won’t be able to enable or disable file sharing.


His user gives the following for groups:

uid=501(ulf) gid=20(staff) groups=20(staff),12(everyone),61(localaccounts),80(admin),98(_lpadmin),702(com.apple.sharepoint.group.2),701(com.apple.sharepoint.group.1),703(com.apple.sharepoint.group.3),33(_appstore),100(_lpoperator),204(_developer),250(_analyticsusers),395(com.apple.access_ftp),398(com.apple.access_screensharing),399(com.apple.access_ssh),400(com.apple.access_remote_ae)

We will install an empty system and see what happens…. :unamused: