Unlock iMac with Apple Watch

I have an Apple Watch 4, and it used to unlock my 2014 27" iMac running 10.15.7, but no longer does. I’ve since disabled and re-enabled the option Security & Privacy, but that doesn’t seem to matter.

Any thoughts or suggestions on resolving the issue? (I could zap PRAM & SMC.)

Cheers!

Bluetooth and WiFi are both enabled on the Mac? (I had this “problem” on my Air because I forgot that I had turned off Bluetooth.)

I had this happen under Catalina I think. Nothing fixed it. Then after a month or so it just started working again. Still to this day, it sometimes just doesn’t work. It’s just really finicky.

Sorry, not a great answer.

Had same issue, luckily someone here shared this link how to fix it.
It worked for me :blush:

5 Likes

Genius! That absolutely worked like a magic charm!

Thanks for pointing me in the right direction!

Cheers!

For anyone else coming across this thread in future, I tried ALL of the fixes that are out there and none worked. It would unlock my Mac mini about one time in a hundred (and startling me in the process). I left it on despite the 99% failure rate because the newer unlock for system preferences did work about 95% of the time. Go figure.

However, one thing I did which has now got the basic unlock working 90% of the time… was to move the Mac. Quite what the problem was that physical location affected OS unlock but not System Preferences unlock I cannot imagine, but that’s what largely sorted it for me.

It could also be the presence of a brand new M1 MacBook Pro on my desk. Maybe the mini knew it had to toe the line more.

The instructions in the link from @RDK have restored this functionality for me, twice.

I wish I had seen that post the first time I experienced this issue (long time ago); I was kind of afraid to perform those steps when I discovered them first, but it worked out fine!

this one (think it’s the same solution) on the MPU forum worked for me, fixed it completely.
Thanks to @aardy

Steps (follow at your own discretion)

  1. Open “Keychain Access”
  2. In “View”, enable “Show Invisible Items”
  3. Search for “Auto Unlock”
  4. You should see a whole bunch of application passwords for “Auto Unlock: XXXX’s …”
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in “Keychain Access”, search for “AutoUnlock” (no space)
  7. There should be 4 entries for “tlk” “tlk-nonsync” “classA” “classC”
  8. Select 4 records and delete (don’t worry if they re-appear, the system repairs this automatically)
  9. Open “Finder” and navigate to “~/Library/Sharing/AutoUnlock”
  10. There should be two files “ltk.plist” and “pairing-records.plist”
  11. Delete both files
  12. Open “System Preferences” and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.