Unlock with Apple Watch on Big Sur

Has anyone else had issues using unlock with Apple Watch on Big Sur?

My Mac tries for a few seconds to unlock using the watch, fails and then I have to use touch ID or insert my password. The fact that the Mac is trying indicates that it is connecting to the Apple Watch but failing for some reason.

Coincidently, yesterday I had to re-pair my Apple Watch to get the unlock with watch to work with the 1Password update. So I have re-paired it recently.

ever since watchOS 7 I’ve been unable to unlock any mac (whatever OS) with my Applewatch series 3.
So might be caused by watchOS?

Mine had been doing that intermittently for months. Even a clean install of Catalina didn’t help. It occasionally prompts me to turn on the feature, but I no longer try.

I had issues after watchOS 7.
Googling gave me this solution which has worked for me fixed it on iMac and MacBook Pro, including after upgrade to Big Sur

Steps (follow at your own discretion)

  1. Open “Keychain Access”
  2. In “View”, enable “Show Invisible Items”
  3. Search for “Auto Unlock”
  4. You should see a whole bunch of application passwords for “Auto Unlock: XXXX’s …”
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in “Keychain Access”, search for “AutoUnlock” (no space)
  7. There should be 4 entries for “tlk” “tlk-nonsync” “classA” “classC”
  8. Select 4 records and delete (don’t worry if they re-appear, the system repairs this automatically)
  9. Open “Finder” and navigate to “~/Library/Sharing/AutoUnlock”
  10. There should be two files “ltk.plist” and “pairing-records.plist”
  11. Delete both files
  12. Open “System Preferences” and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.
5 Likes

Unlock from Watch had been intermittent for me on both Mojave and Catalina. Might well be going to BIg Sur later this week - but I don’t expect this to change.

Mine works ok and has been working during all the Big Sur and watchOS betas. I have S5 watch and Imac 5k Late 2014

1 Like

Try to log out of Apple ID on your Mac. Once you login back you will be promted to insert password on your iOS devices. It worked for me.

worked!
thanks a lot, this has been bugging me for months

2 Likes

Thanks for this. Fingers’ crossed.

I’ve also lost since Watch OS 7 the ability to use the watch to unlock locked panels in System Preferences.

There were actually 16 entries – four for each watch that had been set up over time for Auto Unlock :scream:

1 Like

I was having this very same problem, but it was solved after updating to watchOS 7.1. Have you tried that?

It apparently was a known bug pointed on the watchOS 7.1. change log:

  • Resolves an issue that prevented some users from unlocking Mac with Apple Watch
1 Like

I had a similar problem with Catalina. It was eventually solved by ticking and unticking the permission in preferences. I am not sure if I had to do it in Safe Mode. I had support calls and the tech seemed to know the problem but didn’t know why what we did was fixing it. I use my apple watch for haptic alerts, opening mac, timers, time and nothing else! so it mattered to me that it worked right. I think the procedure was similar to what @TheMarty says above. I can’t remember the exact process. I think I had to log out and make sure stuff was ticked properly too.

2 Likes

After I posted this I had some success!

Please note, the day before I had re-paired my Apple Watch with the Mac so I think this definitely helped. But really I just reset my phone, watch and Mac and it started working.

2 Likes