Unresponsive finder to touchpad or mouse

Spent a frustrating day when my Mac Studio M2 desktop would not respond to my mouse click (right click was first I noticed) or touchpad click or right-click!

Tried to reboot finder, then a first re-install of macOS Sonoma, followed by a complete clean reinstall, working fine again, adding apps back gradually…until it started again.

Uninstalling last few and then all apps did not fix it. Back to a MacOS reinstall, didn’t fix it.

Another clean reinstall didn’t fix the problem, so I attempted another clean reinstall (with the feeling of doom that I might be taking my Mac Studio to a Service Provider).

However, Finder responsiveness to mouse/touchpad clicks returned.

Some weeks ago, I deactivated the annoying click wallpaper to reveal desktop clearing action, was working fine. Been working fine on my MacBook Pro M1 Max and this Mac Studio.

After deactivating this on Mac Studio after this last clean resintall, seemed to trigger the issue, when I activated Click wallpaper to reveal desktop ‘Always’ with Desktop and Stage Manager, seemed to fix the issue!

Obviously not impressed that this glitch had me do some serious reinstalls and seemed to be an issue with the option to get rid of reveal desktop!

Wanted to share in case anybody else has a similar issue.


And just in case there are others running into this problem (or possibly family of related problems), there’s also a discussion going on at the Apple Community Support forums: Strange Mouse Click Issues.

Various solutions proposed there, but unfortunately nothing that seems to have worked consistently for everyone so far. What works or doesn’t work seems to depend on system configuration (external monitor vs. laptop display; Apple mouse vs. Logitech, etc.)

1 Like