USB C External Drive - Won't Eject

Hey all, my primary computer is a 2017 MBP - 16gb of ram, running macOS 13.2.1. I’ve been backing up photo libraries to a 4TB external drive, USB C, from Crucial (Crucial - X6 SE 4TB External USB-C/USB-A Portable SSD). I use the USB-C (there is a C to A adapter, but I don’t use the adapter). Recently, after backing up photos, I tried to eject the drive and it would not eject, said it was still being used. I individually quit each program (photos, word, safari, etc) until finder was the only remaining app, yet the drive would not eject.

I had to leave for work and needed to take my laptop, so against my own judgement, I simply unplugged the drive. In the past, when doing this, sometimes it causes errors with my Photo library on the drive, but it’s not consistent.

Any ideas of what may be latching on to these things?

1 Like

I’m not sure, but I’ve had it happen, and in those cases I usually just restart my Mac which seems to do the trick


It’s really difficult to know. Sometimes when this happens, I check Activity Monitor to see if something in there looks likely. But it can be tricky to just kill off a process without knowing what they’re really doing! For a while it was Spotlight that was grabbing things, but for me (running Ventura now) that hasn’t happened in the last year or so.

Sometimes Disk Utility will eject a drive when Finder won’t. Sometimes. And perhaps it really isn’t doing anything but the disk ejects because the OS has finally finished whatever it was doing….

If that fails, I usually shut down my computer (assuming I have time). Otherwise, I’ll risk yanking the disk, as you did. (I then run it through Disk Utility when I have a chance, just in case there’s something easily repaired.)

Apple claims you can try logging out and then logging in again. (I never remember to try that because I’m the only user of my computer and thus never log out.)

1 Like

In the past I’ve opened Activity Monitor and quit programs 1 by 1 until it allowed me to eject it.



So I came home and went plugged the drive back into my computer. The litmus test is whether or not it will allow me to open the iPhotos library.

Where we live, our internet is spotty, so I can’t use iCloud for my library. Plus, in all honesty, it confuses me. I have no idea what is where and don’t really trust it. So this 4tb drive has our 2tb+ (which is also more space than I have on my internal drive) of family photos. We have a second that is our backup/travel drive, then we have copies on other spinning drives in a few locations.

When trying to open the library after the disk could not be properly ejected, I get this error: Photos was unable to open the library “2022 Current Library”. (5416)

My other portable drive has done that a few times, but for whatever reason it has sorted itself out. Now, however, because both drives were in the computer when I couldn’t get it to eject, both are giving the same error.

ANOTHER UPDATE: Two restarts later, they are both working. Sigh.

photoanalysisd is a non-user-facing process that routinely accesses your photos independently of the Photos app. If that process is working on your Photos Library you will not be able to eject the drive (and you should not). There may be other such processes.

In Terminal, you can see what processes are accessing your Photos Library with this command:

lsof <path_to_photos_library>

<path_to_photos_library> might be something like /Volumes/My-External-Disk/2022\ Current\ Library

[In Terminal you must “escape” the blanks in a pathname, hence the backslash-space sequences above; you could also quote the path name like ‘/Volumes/My-External-Disk/2022 Current Library’ and omit the backslashes.]


Thank you! I’ll try that one tomorrow. Does it hold on to the drive for long periods of time? For example, I tried to eject the disk Sunday night, it wouldn’t let me, and still wouldn’t Monday morning.

I’ll give this a try and see how things go.

Unfortunately there’s no way for us mere mortals to answer this, and anyway it may not be the only candidate.

1 Like

photoanalysisd works in the background on your photos when you’re not using the app. So there’s a possibility it could be using it at any time.

1 Like