Using G-Suite in Safari for iPadOS

Safari (in desktop mode) in iPadOS opens my Google apps instead of working in browser as I had hoped. Does anybody know how to fix that. Do I have to delete my Google apps?

I have to use it on iPad since the public beta of Catalina basically broke my MacBook and I have to get my work done on iPad (I know, my fault for putting it on my daily driver…).

The people I know using iPadOS beta are able to log into their Google Apps with Safari and remain in it. Are you using the beta?

Yes, I’m using the beta and every-time I try to sign in , it starts the app and throws me into the app.

Odd. I’d try deleting the app(s) and see if Safari loads the site.

From what I’ve seen reviewers are getting in fine in Safari.

That happened to me for For a long time they did everything they could to push you to the mobile app when opening the actual tabs. Today, I went to the site via safari, found a song I wanted and clicked the link and it took me to the app instead of a new webpage. So then instead, I long clicked the link to the song I wanted and “opened in a new tab” and that worked for me.

Maybe delete the drive app? I’m going to try that with the ultimate guitar app.

1 Like

Deleted all Google apps and now it works!!!