Ventura Upgrade gone horribly wrong

I’m trying to upgrade my MacBook Air from Catalina to Ventura. I made a full bootable backup first.

Did an in-place upgrade.

After the install systme would not boot. Booted in recovery mode, checked the disk no problem, then rebooted and did a reinstall of ventura off the network.

This all appeared to work (several hours later) but now there is only a single user and it’s a standard user and I can’t add an admin one.

Any suggestions before I restore from my Catalina backup and try again?

macOS is supposed to prevent having no admin user accounts, and when you do a fresh install it creates a single, admin account.

So I’d suggest doing another reinstall of Ventura. For good measure, name the account it creates “Admin”, log into it, connect the backup drive, and use Migration Assistant to move your account(s) from the backup drive.

All this said, when I went to upgrade to Ventura on my iMac, the system died (main board failed) in the process. A repair at Apple and I had a fresh Ventura system and had to do the above. No problems with the accounts, but most of the applications did not move over without errors. So it wasn’t exactly a quick upgrade.

On two other systems Catalina to Ventura went without any issues whatsoever, so it seems to be just luck.


Tried that, no go, Tried to boot off my Catalina bootable drive but it’s not found so I can’t although I can see it if I plug it in.

PS I never get asked for an account to create when I did the reinstall. In fact never got asked the first time either.

Is your MBA 2018 or younger?
You skipped 2 Major Versions on that Upgrade!
I would never do that as a installation over the old Version, but would do always a clean install in that special case!

1 Like

Looks like you aren’t the first one to have this problem. I googled:

Missing admin account ventura

And found several references to the problem including:


I have 2 machines. I need them to be at the same system all the time. My other machine is a 2013 iMac and cannot go higher than Catalina. The MacAir I was trying to upgrade is a 2019 machine. I wanted to upgrade it first so I could find all the software that I can’t update on the existing Catalina systems because new revs won’t work. So I was planning on downloadnig and updating my suite of apps and verifying that my critical functions still work on the laptop before moving to my new MacMini. And how exactly would I do a “clean Install” in that case?

Thanks, I started searching for that as well after the first failure but the only solution I found had never been tested on Ventura.

The exact same way, a clean install is always been done!

  1. Backup
  2. Erase the Drive, best with at least 4 Runs.
  3. Install the new OS
  4. But everything you need back on your Device from your Backup.

I think you missed my point about maintaining consistence among the system.

In any case the issue now is that the recommended install has failed.

Latest Update:

I was unable to boot of an external drive, tried recovery and my bootable backups did not show up as options. Tried several other fixes to create the admin user by going in via terminal from recovery mode but was unable to locate the proper places to make the suggested changes.
I tried the versionto reset the setup done file

rm -i "/Volumes/Macintosh HD - Data/private/var/db/.AppleSetupDone"

But the only volume on the machine was an update volume and it did not have the data partition that I could find even after choosing show all devices from the recovery version of disk utils. I also did a first aid on the drive from the recovery disk utils but no errors were found.

My MacBook has the T2 security chip so I was going totry to make sure that I had it set to allow boting from other drives. I believe I had done that as soon as I found out about it when I first got the machine but I thought it might be worth a try. Unfortunately it requires an admin password to get into the security settings and again the now admin on the system issue.

So was about ready to hand the system over to my husband to see if he could boot a linux system from the USB port.

The Ken effect was in full force. He wanted to see it not booting or even showing the option to boot from the external bootable BU. Of course with him watching with a Linux USB stick in hand the system DID show my external BU drive as a boot option. So I did that and use CCC to restore the hard drive. Interestingly there was an Update volume of 1TB (the one I could see in the previous steps trying to fix he admin issue pieces) and a Macintosh HD -Data - Data volume. Yes with 2 Datas in there. after restore the Update version was gone.

So I’m back to what it was, I created another admin user, made another bootable backup on a different external drive and also got into the Startup Security Utility and set it to no check on the bootable system at all and verified that it was set to allow booting off external drives.

So right now I believe I’m in a position to be able to boot off my external drive and erase the drive and do a clean install of Ventura.

1 Like

Where is a “consitstence” if you have one system that is stuck to Catalina, and one system that is upgraded to Ventura!?
Erase your system with the DiskUtility from the Device, and do a clean installation thereafter from the Internet.
The Way you get to the DiskUtility is described here.

The use of the DiskUtility here.

My laptop is an Intel machine Per those instructions
" Before erasing your Mac

  1. If you want to restore your Mac to factory settings, such as to prepare it for a new owner, learn what to do before you sell, give away, or trade in your Mac.
  2. If using macOS Monterey or later on a Mac with the Apple T2 Security Chip, follow the steps to erase all content and settings instead of these steps.
  3. Make a backup of any files that you want to keep. Erasing your Mac permanently deletes its files."

Note that it requires Monterey or later AND requires access to an Admin user to do it!

Yes, thinks like this are happening, if someone tries to run an update while skipping several Major Releases of an OS.
From your description in #10 (which was shown the same moment I sent my reply #9), it seems that you are back where you now could go the way to do a clean installation.
If you, or someone else reading this in the future, run into problems with the Adminpassword, here are some hints that might help solve that problem.

Oh, and BTW, I would with the modern OS´s never run my system as a “User”! I always running my systems with Adminaccounts, so I do not run into a problem like that in the first place.

1 Like

At times in my career I did a lot of the packaging of our enterprise offering. Many clients had their own AIX servers and did their own application software upgrades. We also had large shared AIX servers in a data center with hundreds of clients. We (often me) did the admin and upgrades on these boxes. I saw first hand the conceptual difficulties of combining the installation of major software releases.

Our major application upgrades, released once or twice a year, had to be run in order, one at a time. No matter what Apple claims, I would never skip any of their major upgrades for macOS. Especially those from the last half dozen years when really major transitions have been made between versions.


I have never used a User account either. As I said it was CHANGED ro a standard use. I alwys run as an Admin.

Just in case it wasn’t clear, you do not need to boot from an external disk if you want to erase your drive and reinstall macOS. The instructions on Apple’s help page are misleading. It seems to suggest that erasing a T2 Mac requires Monterey — when, in fact, Monterey just has a different way of erasing.

If you are going to erase and reinstall, I would not do it while booted from an external drive. Mostly because it’s not how Apple suggests?, but also because it might be much slower.

Here’s how to do it the “Apple way”:

Sine this boots the Mac from a different partition, the lack of an admin account is irrelevant.


Good point, but I’ve had Apple machines since the very first Mac 128 and never had a problem no matter how many generations of operating system updates I skipped in between upgrades.This is a new issue for me. Since I tend to keep machines in use for years I’ve done the skip multiple systems a lot over the last decades.

1 Like

The fallacy underlying the I’ve never had a problem doing something a certain way is that it describes only past experiences, and only your past experiences. It may be an indicator of future performance but it is no guarantee, as you have laid out in this post.


There‘s nothing wrong with upgrading to the newest release. And I‘ve done it countless times for customers. When someone brought in a machine on 10.6 or something when 10.10 was new, I certainly didn’t go through the trouble of installing 10.7, 10.8 and 10.9 first (in that order) and charge my customers many times for the service.

Apple expects you to do it that way: Skipping intermediary updates to upgrade directly to the newest OS. They weren’t even offering intervening OS versions publicly when OS upgrades were done through the App Store.

Such backups, on the other hand, have been unsupported or deprecated by Apple for a few years (see this explanation from the makers of Carbon Copy Cloner, for instance).

What I would do and recommend now:

:point_right: Boot Recovery over the network (not from the internal storage’s recovery partition, if available), wipe the HDD/SSD, install a clean new version of Ventura. Then import via Migration Assistant.

They do it through the Apple Store normally as a clean Install, not as an installation over the other system. That is one of the Reasons, all datas are normally gone, if you get the Device back!
And if you did it like you described, you where just in a lucky position, that it never fires back to you.
An OS like macOS is a very difficult kind of written code, with thousands of errors within this code!
Those Errors are normally adressed, if they become obviously, by future Updates.
If you skip major releases during an Upgrade, you have a high chance, that those mistakes of the different releases are combining with each other in an unexpected way, and that you will end up with visible Errors like the one described in this Thread, because the Version 13 are addressing mainly the errors of Version 12.x and not of Version 10.15.

I would rather guess, that you just did not use the functions with the Errors you “build” into your system by doing so.

Even if you are doing every single Update that becomes available, it is an very old golden Rule, to do a clean Install at least every 2-3 Major Releases to keep the System in a good health. And this becomes more important, while the OS´s are becoming bigger and way more complicated.

1 Like