Very frequent Fantastical alerts (probably from Catalina) - can I stop this?

Every time I click on an event in Fantastical, I get this wonderful notification. Every time. Is this a one of the Vista-like notifications of Catalina? Is there a way to limit this? Google searches have come up dry.

Thanks everyone!! Happy Thanksgiving (US MPU’ers) and holidays.

“Fantastical 2” would like to use your current location.

Fantastical uses your location when using geofenced reminders and when creating events or reminders with locations.

Try going into privacy settings and see if Fantastical 2 is checked as having access to location. Maybe the choice isn’t sticking for some reason.

You shouldn’t get asked every time.

Thanks for the hint, Wolfie. It was unchecked for some reason, but checking it didn’t fix the problem.

Go to disk utility and run first aid. Might be a permissions issue.

Did you contact FlexiBits support? They are prompt and very helpful.

Katie

Did you turn off location based settings in the app (e.g. “Automatically activate at location”)?

Thanks TheMarty. I thought that “Automatically activate at location” was turning on geofencing. It seems to ask for a particular address when I check that box and has “Arriving” and “Leaving” as options. I tried it anyway, and checking this didn’t fix the problem.

Disk Utility didn’t help either. That was a great suggestion though, Wolfie. I forgot about that. Haven’t had to run that for a long while.

I’ll contact FlexiBits Support. Thanks for everyone’s help!

Having this too. How did you resolve?

I didn’t. I still suffer from it.

Found this thread because I’m having the same issue. Assuming there’s still no solve?

+1, seeing this every time I open a notification.

I updated System Preferences -> Security & Privacy and ticked Fantastical Helper. Afterwards I opened ‘Activity Monitor’ and force quit Fantastical and Fantastical Helper.

After reopening both, the issue appears to have been resolved.

Update: This setting seems to revert once a week which is still quite annoying.

I just turn on notifications for the native Apple Calendar app and turn off notifications for Fantastical.

It’s like Twitter. I keep the Twitter app on my iPhone to get notifications but mostly use Tweetbot when I’m in the Twitterverse.

I had an (unearned) reprieve from this behavior for a while, but with 3.1, it’s back with a vengeance. Fantastical 3, regrettably, has made the app harder for me to love.