Very long print delay (hours) in Big Sur(ly)

I had tried printing a PDF from my Macmini, but the pages never went to the printer.

The print dialog showed 16 pages were sent “somewhere” but the printer never came to life. I looked in the print queue, but couldn’t even open it. I then tried printing the PDF several more times, all with the same results. So basically, I had 4-5 copies of that PDF hiding in the print queue, and couldn’t delete them.

I then moved to a Windows 10 laptop and was able to print the PDF on the first try.
Hours later when I was in bed, I heard the printer come to life and start printing. Fortunately, there was a paper jam, so I left the printer in that state so it wouldn’t waste paper and make noise.

In the morning, I tried opening the print queue again but could not. I then saw a Reset Print system option and tried that. Apparently, that deletes the print queue.

Have any of you seen an hours-long print delay like this?

Oddly enough, this was the same day I had nearly an hour support call with Brother, due to (differnt) printing problems from iOS & ipadOS. During that call, I had mentioned that I wasn’t seeing the issue on MacOS. :wink:

Never. Not on Big Sur nor any previous OS.

Printing issues can be any combination of printer hardware or driver, macOS print daemon, macOS, the document contents (including corruption), etc. etc. If you reboot in Safe Mode you might be able to check out performance with minimal other factors at play.


I have a Brother MFC-J985DW and have had no issues printing from Big Sur (or Winders, or iOS). But I’ve debugged enough printer issues at work to know that it could be just about anything (including a Big Sur bug that I just haven’t run into).

Standard stupid things to try… Reboot, reinstall, re-run.

I hate printers…

1 Like

For me, iOS and iPadOS have been the most problematic. When I select double sided, the pages come out single sided. Or one page will come out, then I wait minutes for the rest. More often than not, I print and nothing happens.
At least on Windows you can update the drivers discretely, you can’t do this on Mac, iOS nor iPadOS

Which Brother printer is this? Sounds really bizarre.

I’ve had issues switch my M1 mini losing track of my hip printer from time to time. This manifests in bizarre ways. Sometimes the printer is just forgotten. Sometimes, like today, it means that efforts to print from a particular app (Word) fail silently which can only be fixed by deleting and recreating the printer in settings.

I suspect there are a lot of peripheral bugs left to be squashed, particularly on m1 macs.

1 Like

It seems the macOS team is playing around with the usb/thunderbolt interface lately. Not every attempt to improve this is successful (to say the least). :frowning:

MFCL-5800DW …,!!!’mm@@@&&$$

Yes, my one of my monitors keeps going squirrelly about once a week. Reseating the adapter from the thunderbolt port is the only fix.