Very strange issue - I keep getting the "Do you want to enable dictation?" prompt when hitting the number 5 key

This is really strange.

When I press the number 5 (or F4 (looking glass) or F5 (mic) or F6 (moon), as it turns out…), I get this prompt:

I looked through the keyboard shortcuts in System Settings and found no shortcut mapped to “5”. I also don’t understand why F4, F5 AND F6 (and as I type this, the number “6” seems to have joined the party…) would trigger this prompt.

Has anyone seen similar behavior? I’m running macOS 12.4. (I want to grab 12.5.1 but have to wait for my employer to fix their proxy config first).

This happens on a 16" M1 Pro Macbook Pro.

Have you spilled something over your keyboard?
From the distance, I would assume, that something is triggering all keys in that surrounding, and Coke for example is a “good” way to do so…

1 Like

Not that I recall, no. Also, the key haptics feel perfect, like the rest of the keyboard. Nothing about the mentioned keys is remotely “sticky”.

It’s probably not the number keys, but perhaps something else you’re doing that you’re unaware of.
Have a look at System Preferences | Keyboard | Dictation, and see if there is a shortcut enabled to turn on Dictation. You might be, for example, accidentally pressing Fn twice, etc. when using the number or F keys.

The microphone key (F5) is the default button to start dictation, if you have it enabled. It looks like you do not have dictation enabled.

However, the real problem is that pressing keys in one area of your keyboard is activating the microphone key. This seems like a hardware issue.

Older laptops were notorious for developing weird trackpad and sometimes spacebar issues when their batteries swelled. So maybe something similar is happening here — something pressing on the keyboard? Might be time for a call to Apple.

3 Likes

I’m not pressing FN at all. More importantly, I don’t see this “Off” option you’re showing:

I would have loved to try “Off” to see if there’s an impact on my behavior. Otherwise I agree that it might be time to call Apple about this.

Try Customize… if there isn’t an ‘off’ option there, try setting it to something you’ll never accidentally press. Not at my computer, so don’t know the options available, but something like CTRL+Shift+Option+?

Still happening. Next step is an appointment with Apple. I’ll let you know what happens… thanks for your suggestions, everyone!

1 Like

By any chance - do you have an external keyboard you could hook up and try?