Video issues once again

A few years back I posted a problem that I was having with my iMac in Safari where video playback would stop working after a certain amount of time of Safari being open. Well, this problem has started to show up again in my M1 MacBook Air. The solution to the earlier problem that I was given by a Senior Tech Support person at Apple was to install Flash Player. Since Flash Player is no longer supported nor developed by Adobe this is obviously no longer a solution. Allow me to describe my experience of the problem and maybe someone can help me find a solution:

Running: 2020 M1 MacBook Air, Monterey (all fully updated), eternal LG 4K monitor for dual screen.

Safari is open for an extended time
Attempt to play a YouTube video
Video presents with a visible play button on the video but is unclickable
Play button at the bottom of the player is also unclickable
Refresing the page doesn’t change this state
Clearing cache and refreshing tab doesn’t change this state
Quitting and restarting Safari often fixes the problem
Sometimes after restarting Safari the page has to be refreshed again for it to work

When the problem shows up again, you could try viewing the YouTube video in a Private Window (File > New Private Window or ⇧⌘N) and see if you’re able to duplicate the issue. Caching and Safari Extensions are active when you’re in a Private Window, so this may be helpful for narrowing down the cause.

If you’re running any Safari Extensions, you could also try disabling them temporarily and, if everything works normally, enabling them one by one.

p.s. I haven’t run into this issue on my M1 MacBook Pro that’s connected to a Dell 4K monitor and running Monterey.

1 Like

Also @lukei4655 If Tim’s points don’t help, does it happen if you don’t attach the external monitor.

It’s not likely to be the monitor, both another thing you can rule out.


I hadn’t thought to trying to load the video in a Private Window. I’ll do that next time round and see what happens. I’m not really running any Safari Extensions right now except 1Password and maybe Honey, and maybe one other. I’ll also look at that just to be sure. I’ll be back next time this happens as I try the troubleshooting that you suggest.

I have experienced it when not attached to the external monitor so I’m pretty sure that’s not the problem. I first ran into this problem with my previous 2015 iMac, so it’s not exclusive to the M1 MBA in my experience. I’m just not sure what the cause could be and neither could Apple Tech Support. The previous advice to install Flash Player was a work-around. But that’s no longer an option.

1 Like

I just ran into the issue again today after leaving Safari open with a YouTube video open and paused in a tab all night. I copied the link into a Private Tab and it worked. On a hunch I the opened it in a new regular tab and it worked but in the original tab the same issue persisted. So, I’m guessing this has something to do with the way individual tabs are handled by Safari. But, if that’s so, it takes me beyond my skill level to solve the problem myself.