VueScan is M1-native, but you may need the Intel version, and stand-alone Intel drivers

I thought I’d post this here as I had some confusion over this situation this week.

I was pleased to see that Hamrick Software offer a Universal version of their VueScan app and I duly downloaded it to my M1 MacBook Pro when I was setting it up. However, when I went to use it, I struck a bit of a snag.

As a background to this, I already had the Epson Scan 2 software installed and working.

When I started the VueScan application it popped up a “hint” that it had seen my Epson Perfection V370 Photo scanner but that “the plugin libraries are for Intel processors”. It then recommended that I try to download the “x64” version.

At first I could not find this version (it’s behind very small link text below the very big download button) and when I did and installed it, I got a new “hint” which said it could not find any drivers for x64 and I should try the x32 version!

I knew x32 was going to be a no-go option so I started mulling over what might be the problem. I dug into the Library folder and found what I believed to be the TWAIN driver and it was indeed a 64-bit Intel binary. Which then led me to the Epson support downloads page. That’s where I’d found Epson Scan 2, but also on that page was a separate driver download.

With that downloaded and installed, VueScan now works. It occurred to me after all this I may have just been able to tell the Universal version to run under Rosetta 2 but it’s working now so I will leave it alone.

If Epson come up with M1 software and drivers I will revisit, but I’m not holding my breath for that. I was surprised they listed Big Sur compatibility.

Any updates? I downloaded the VueScan trial and it didn’t find my scanner (Epson V600). Epson Scan 2 works. Didn’t have time to dive into the problem…

I have an M1 Mac mini and an Epson Perfection V550. I originally dowloaded the Universal version (VueScan 9.7.55 a64 (ARM64)). When I tried to use that app, it did not see my scanner. I then downloaded the Intel Version (VueScan 9.7.55 x64). This version worked fine. So try what @zkarj says above. Right click on Universal version of VueScan app (which is the version I think you have) → Get Info → check Open in Rosetta 2. See if that works. If not, try the intel version. Also, make sure you have the latest version of the Epson drivers.

On a side note: I had some B&W negatives that I first tried scanning with the Epson Scan 2 software. Most worked fine but there were a few (maybe shot with different B&W film) that had some horrible pixilated areas despite my trying various settings. I must have scanned those 5-6 times each, but all with the same terrible result. After I downloaded, installed, and used the VueScan software the scans of those negatives came out great.

Still don’t know why the Intel version of VueScan worked on my M1. Is it running under Rosetta 2 and I don’t know it?

Thanks, will try that. I have the current Epson drivers on my M1, so that should not be the issue. And, while Epson Scan 2 does work, VueScan delivers better scans. But I want to get the demo version working before purchasing a license.

1 Like

Just came home and tried the trick. Opening the Universal version with “Open in Rosetta” enabled did the trick.

1 Like

Hitting the same issue on my M1 Mac Mini. Posting the full “tip” text here for SEO purposes:

VueScan found an Epson Perfection V600, but the plugin libraries are for Intel processors. Try downloading VueScan x64 from www.hamrick.com. Also, make sure you’ve downloaded a driver for this scanner from www.epson.com.

Press ‘Close’ to start using VueScan.

Screen Shot 2021-06-14 at 11.14.55 PM

after Get Info > Open using Rosetta I then get the Tip:

VueScan found an Epson Perfection V600, but wasn’t able to find a 64-bit Intel plugin for this scanner. Make sure you’ve installed a driver for Mac OS X 10.6 or later from www.epson.com and also try downloading VueScan x32 from www.hamrick.com. Note that scanner drivers for Mac OS X 10.6 or later usually work with newer versions of Mac OS X, regardless of what the Epson web site says.

Epson Scan 2 (newly downloaded) works fine on the M1 Mini.

I’m using VueScan 9 x64 (9.7.56)

That “Tip” is completely unintelligible; what architectures of VueScan and/or the Driver are available and should be installed on an M1 Mac?

EDIT:

I installed Epson’s driver ICA Scanner Driver v5.8.9 for Image Capture, posted 01/05/21. VueScan now works (when set to Rosetta), as does the Image Capture default app. If I uncheck the Rosetta box, VueScan no longer will recognize the scanner.

So:

  1. Install the Driver, not just the Epson Scan 2 app.
  2. Set VueScan to use Rosetta.
1 Like

This all means our old scanners which have been usable beyond the offer of current drivers are now definitely living on borrowed time. Rosetta 2 won’t be around forever.

1 Like

We are probably covered for the next year. Then either get a new scanner or look at alternatives.

1 Like

Certainly more than that. But VueScan meant for the longest time that you were sure your antediluvian scanners worked forever. This is simply no longer true (not for the VueScan developer’s fault).

I’m moving house at the moment so can’t investigate but I wonder if something like Parallels and the Windows install might work for some people. I’ll certainly try that once I’ve got my stuff back in one location

1 Like

Thanks for offering, but virtualizing Windows on M1 probably won’t help much. We first need the ARM version (which still isn’t public) and the problem of translating ARM drivers will present itself just as well.
Indeed, better buy a new device that works natively if it comes to it.

1 Like

Sigh. I got a new office desk and had to take everything apart. Now I have it all back together my scanning is a nightmare of crashes and hangs!

VueScan would either get stuck on Calibrate… or just crash, leaving the scanner flashing away as if it were doing something when it wasn’t. I tried a different cable in a different port. Same problems. I tried running Epson Scan 2 which did the preview and started scanning and then reported it could not get data from the scanner. So I switched cables again and it managed four frames. But that was the cable I had started with.

So I ran VueScan again and it seemed to be going fine, then I tried to resize the window while it was scanning and it crashed, so I suspect Rosetta. I quit everything and started again and it seemed to be going OK, so before taking a break from the computer I told my micro-pause software I was taking a break now which puts a ‘shade’ over the entire screen. I left the room and when I returned some minutes later I discovered it had hung on the second frame of four.

I’m suspecting Rosetta is getting fussy, or VueScan is getting fussy about Rosetta, but there’s little I can do about that. I checked for new drivers and while they now mention Monterey, the download says “Mac OS X - PowerMac, Mac OS X - Intel” but it does have “10-2021” so I guess it is a new version. I will give that a try, but man I am sick of this drama!

I also noticed a link on the support page that said “how to download the latest drivers” and had a look. It mentioned using the “Printers and Scanners” pane in System Preferences. I tried that and macOS did detect and add my scanner, though it called it a GT-S640. I checked and that is an alternate name for my V370. But… that does not appear as a source in VueScan, even if I run it in native ARM mode.

I wanna get Apple and Epson and bang their heads together. “It just works.”

So far it seems stable with the 10_2021 driver, but I daren’t try to resize the window or anything else to interrupt it.