Wake up with keyboard not working

All of a sudden my Mac* won’t wake from sleep when touching the keyboard. The mouse or trackpad do the trick, but I am used to touch the keyboard and it’s annoying as h*ll that it doesn’t work. Neither the built in keyboard nor the magic keyboard works.

*I just got a MBP 14" M1, but I am quite certain that it worked when I got it last week – I think I’d have noticed this behavior if it was from the start. But I have also installed software during this week, that may interfere somehow (why that would be so I don’t know).

Any ideas?

I did a restart in Safe Mode, and now it’s working as it should (even after starting normally again)… :thinking:


Nope, I was too quick on this. It still behaves the same way, Difference is that the Mac went to the screen saver by itself and I have been away from the computer approximately 30 minutes.

Any ideas…? :frowning:

I can’t provide any advice because I haven’t figured out how to fix it on mine either! MBP 14 users too- I’m using an apple extended KB with it

I’ve had this problem for a while when connected to a Caldigit TS3+ dock. I have to jiggle the mouse, push some random keys, and sometimes manually turn off and on the external display as well.

Annoying as hell!

Interesting… I’m also connected to a Caldigit hub. Wonder if that’s the culprit

No Caldigit here. I have tried with nothing attached, still same thing. But the problem only shows after a while (ie, >5-10 minutes). If I put the Mac to sleep or turn on the screensaver, I can immediately wake it with the keyboard. But not after a while.

Update: Life now better!
I installed these drivers from this page, and the only problem now is that the damn display doesn’t turn on when I wake the computer with the mouse - but I solved that by simply turning on the screen first, and letting that wake the computer :slight_smile:

Note: Drivers are a kext, and require that you allow third party kexts. This is INCREDIBLY kexist, and…
Sorry… My wit ran away with me… It’s a bit insecure, and you have to reboot your computer a few times to allow it, but I’ll still do it.