Watch os5 and Apple Music Streaming is dead

So excited to get my new Apple Watch series 4 LTE running Watch os5. My expectations were that I could leave my phone behind as I walk the dog and still stream podcasts or Apple Music. Unfortunately, that just doesn’t work. After trying a hundred things to resolve the problem I called Apple Support. Everything they suggested I’d already tried. So in the end, streaming is just glitchy at best and dead at worst on the new Apple Watch 4 LTE.
Just wondering if I should continue to pay for the LTE service and hope for a software fix, or trade the LTE version in for a basic watch and use my phone for connectivity. I hate that it doesn’t work as expected. I so wanted to leave my phone out of my gym shorts while I walk and run with my dog.

Any advice would be so appreciated.



I can’t offer a fix, but my advice is trade down IF the only thing you want LTE for is streaming. I would rather be inconvenienced by downloading content in advance than dealing with glitchy streaming. Runs/walks should be a recharge, not a ball of stress :slight_smile:

Thanks for the reply. I sure wish it was just user error. But Apple all but conceded that streaming doesn’t work as expected if at all. I’ve got another 13 days to play around with it. While I openly admit to being an Apple fanboy, I must say the Apple Watch user experience has never been very good. This is my third watch and I was hoping for better.

I get it. I really like my watch a lot, but I’m still on Series 2. I didn’t bite last year, and I’m still just sniffing around…

I assume Apple Support mentioned that cellular streaming on the Watch requires a few settings on the phone:

Settings > Music > Cellular Data > Streaming

I frequently have to reboot the watch because it loses the cellular connection.

Hi. They did NOT mention this. What? I finally discovered this setting prior to reading your post, made the change, and still no luck. I then rebooted the watch and it worked!

Now, for those reading this thread, I will share that the “disconnect” feature took a few minutes to occur. Meaning, as I walked away from the wifi in my house and iPhone on my desk, it took about 5 minutes for the LTE connection to kick in. Once it did, I asked Siri to play the Beatles. After another short delay (feels like a long time but probably not very long) Let it Be cued up. After that, Siri worked as expected and other than the delay to fetch music or a podcast, it worked.

Thanks for everyone’s help. I can’t believe I missed this setting.