WatchOS 7.3 on Series 3 Nightmare

Dr. Drang lays out his experience here: My watchOS 7.3 adventure - All this

Mine was similar but the end solution was slightly different. What finally worked for me, HOURS after beginning my journey, was the following:

  1. Unpair from phone
  2. Turn OFF phone
  3. Connect watch to working WiFi
  4. Process software update from the watch
  5. Turn phone back on
  6. Re-pair phone and watch

I think I’m done with updates on my watch. That was painful.

I hear you. My WiFi Series 3 would not update to Watch OS7 after 3 attempts. Ended up replacing it with a new SE model which works and updates much better. You might consider doing the same.

1 Like

I had forgotten that I hadn’t successfully updated to 7.3 yet until this post. If the only change is the addition of Fitness+, then there’s no reason for me to go through the trouble.

@tgara, I get what you’re saying but spending a couple hundred dollars on a replacement watch just to get software updates working properly seems a bit much. This is clearly a software problem which Apple can’t be bothered to fix. As petty and pointless as it may seem, I’d rather not endorse this behavior by throwing more money at a new watch.

As long there’s no compelling reason for me to upgrade the software on my watch or the watch itself, it’s easier to just let it sit on the current version.


I’m still on 7.1 as unpairing, and restoring the Apple Watch just to update it is not how I want to spend my afternoon. Not even sure if the next version with the Watch unlock with FaceID would work with Series 3. So I don’t know if that would compel me to go through the hassle.


nooooooooooo! :scream:

Yeah, that’s what I ended up doing on my wife’s Series 3… just leave the software alone and don’t upgrade. She uses her Series 3 as a gym watch only, so as long as it can do that she’s OK with it. For me, I was planning to upgrade anyway, so the software upgrade difficulties just gave me another excuse to do it! :grin:

What’s upsetting to me is that Apple knows that Watch OS upgrades are a problem on the Series 3 (due likely to insufficient memory from what I hear) yet continue to sell it. I completely understand how people can be angry about it.

it feels like someone at Apple is thinking “What? It is difficult to update our OS on older hardware? Oopsie!” and just generally avoiding working on issues like this for older devices. Kind of insulting, tbh…


Apple should point that Apple Watch Series 3 is compatible-ish with watchOS 7.3.


Oh, no. It’s completely compatible. But is it upgradable from a previous version? Not easily.

1 Like

Yeah I know, been running one myself.

It was just a joke considering that the upgrade itself is a feature that almost feels like it is missing.

Guess it wasn’t that good as a joke! :man_shrugging:t2:


My series 3 failed to update on each of the latest WatchOS 7 updates. Had to remove and re-pair. This last time, I just caved and bought a used AW 6 from FB marketplace. I also want more storage space for music, which the 3 was very skimpy on. I can resell my series 3 to someone else with lower needs.

1 Like

Had to go through the peril of updating to 7.4 yesterday (the entire afternoon) after holding off not updating from 7.1 to all succeeding updates. I have to do it all over again for my girlfriend’s watch today because she doesn’t know how to deal with it as she attempts to delete all of her apps to still get an error about updating to the latest update. When Apple fudge everything it, they really make it painful for their customers.

1 Like

Also had to un/re-pair my Series 3 to install watchOS 7.4.

But “Mask ID” is so worth it!

1 Like

I unpaired and re-paired and it still won’t install. Held out on the last update or two because of the stupid Series 3 bug where the update thinks there’s no space even though there’s plenty. I thought the re-pairing also upgraded to the latest watchOS when you did it - what did I miss?

I have the series 3 cel and it went fine.

I has been able to upgrade my series 3 previously by restarting it; that seemed to free up enough memory to complete the update. 7.4 was just too big, so I had to go the unpair/re-pair x3 route. Like the others, I won’t do this again, and I might not have done it this time except for mask unlock.

No, it only clears up (enough) space, but then you still have to manually update watchOS.

Wife’s Series 3 watch for the gym would not update to 7.3 or 7.4. Frustrating, but it gave me an excuse to get her a new SE for Mother’s Day… :grin:

1 Like

I went so far as to unpair my S3, set it up as a new watch (not restore from backup), set it up to not be loaded with music, made sure no apps were loaded, restarted, and it still didn’t think it had enough space to upgrade.

That was a multi-hour venture and I just don’t want to keep fighting it. So now I have an alert set up on for the S6. It feels wrong to be “fixing” the problem by buying another $400 watch but A) I really like having an Apple Watch and B) this one gave me 3 1/2 good years.

1 Like

Only the regular S3 is having a space problem due to the 8GB space. The cellular version has a higher storage space.