WD My Passport Wireless Pro drive — odd behaviour on M1 MacBook Pro

I’m posting this in case it helps anyone else, because I tore my hair out at the lacklustre support response from WD. Love their drives, but support is not great.

The WD My Passport Wireless Pro is a battery powered hard disk drive (I have the 2TB model) that is effectively a wireless NAS. It has two modes of operation:

  • Plugged into a USB port it acts as a simple portable hard drive.
  • When not plugged in to USB it either broadcasts its own wifi or joins another wifi network you configure

When in the wireless mode you can stream media from it or access it like a NAS. However, copying large media files to it can be done faster over USB 3 than wifi (Wifi 5/ac). I’ve had the unit for two years and often plugged it into my Mac mini to transfer files on or off. When I first tried plugging it into my M1 MacBook Pro things did not go as they should.

Normally when you plug it in to a USB port, the wireless light goes out and the computer sees it as an external drive. When plugged into the MBP, it remains in wireless mode and the device does not even appear on the USB bus. However, it will take a charge from the USB port.

What I have discovered is the drive will either take a charge from the port or offer itself as a storage device. Because both of the MBP’s Thunderbolt/USB ports offer high power, they are only of use for charging the device.

I tried plugging it into the front USB port on my OWC USB-C dock and had the same problem. The front port is high powered. I realised what was going on when I got it to work through a cheap StarTech dock, that does not provide high power. Sure enough, when I plugged it into the back of the OWC dock, on regular USB 3 ports without high power, it works as a storage device.

I’ve told WD that this is happening and their response basically indicates they don’t understand what I have said. So I don’t know if this is something about the MBP’s behaviour or Big Sur’s behaviour or the drive itself. I guess the (2018) Mac mini ports are not high powered?

1 Like

Are you sure this isn’t cable-related? USB-C and Thunderbolt cables come in many physically identical configurations, exasperatingly.

To the best (or limits) of my knowledge both cables I was using are USB and in any case they work fine with the Intel Mac mini which is also Thunderbolt on the USB-C shaped ports. The drive end is that thin USB-B variant that hard drives seem to favour these days.

Same exact problem. I’ve tried THREE different tickets with WD, and they just keep looping me back to the same article that doesn’t help at all. I’ve tried multiple cables, and all 3 ports. I even tried downgrading firmware, but no luck. No change for you either?

No change. I just keep that StarTech dock handy and use it as the ‘insulator’ between the drive and MacBook Pro.