Wemo No Longer Certified For HomeKit?

Last Fall I went a little crazy and bought a bunch of Wemo plugs when Costco had them at a pretty good deal of 2 for $25. They had some quirks joining HomeKit to begin with but I was able to get them joined without too much effort, if I made sure to be connected to my 2.4 GHz ssid. However, I recently moved and had them unplugged for a couple months. Attempting to add them back fresh, cause things moved around when we moved to a new place, I reset the Wemos. Now when I attempt to add them HomeKit complains and says that it’s an “Uncertified Accessory”. I tried to set them up manually by connecting to the switches directly, but both my iPhone and iPad desperately want to add them to HomeKit. Anyone else hitting this problem? Anyone know a workaround to have the iPhone or iPad not add these to HomeKit? I’m wondering if they need an update or something from the Wemo app itself.

Did you enter manually using the Wemo app? Do you know if the firmware is updated to the latest version? If so, check out these tips.

I’ve tried both using a copy of the HomeKit sticker and manually entering the code. Both yield the same results. My theory is that it’s behind on firmware, but I can’t update the firmware without getting it on WiFi through HomeKit because all I have are iOS devices to set them up. If my theory is right, it’s quite the chicken/egg problem. I’ve tried joining the wemo’s setup network, but iOS really pushes HomeKit enrollment for this hard. I even went so far as to delete my home in HomeKit and disable the Home app.

What does the Wemo app do for you?

I have tried adding them through the Wemo app directly. One way will pop me over to HomeKit, which doesn’t allow it to join saying it’s “uncertified”. The other method in the app directs you to connect to the plug’s wifi. However, because iOS’s wifi settings sees this as an accessory it seems to always direct me back to HomeKit. I did have a moment where it connected to the wifi and the Wemo app allowed a manual setup, but it seemed like my iPhone eventually figured out it didn’t have an Internet connection and swapped back over.

I’m not sure what caused things to start working, but some combo of the following made things finally click for HomeKit.

  • Deleted existing home in HomeKit
  • Cycled both Apple TVs in the house
  • Took the router out of bridge mode into DHCP
  • Removed the separate 2.4 GHz SSID (It used to not join without this)

¯\(ツ)

1 Like