What is using up so much storage space?

I run my late 2015 iMac from a 500gb external SSD boot drive. Suddenly I have only 38GB spare storage despite thinking I had used about 220GB.

Disk Utility shows 445GB used as data. By summing all the storage shown by using ‘get info’ on folders I estimate 250GB. The mystery would seem to be the 217GB of ‘other’ as shown on System Information:

image

image

I can’t seem to account for this ‘other’ storage by adding up the space used by folders in finder. Before I get further to adding up the sizes of lots of folders, is this ‘other’ storage likely the problem? What could this ‘other’ be to be so much, in addition to the photos/document already listed above in the System Information?

I have emptied downloads folder and trash. Time Machine backup to another external drive ([EDIT: but which has been giving me problems lately and disconnecting]. Dropbox and OneDrive both installed, and included in my estimate of usage. [EDIT in response to post below: I also back up to Backblaze].

Where should I look next to resolve the issue?

1 Like

Guesswork on my part, but do you run Time Machine and have left the Time Machine drive disconnected for a period? I think it does local backups on the system drive if it can’t see the target drive.

Another space hog I’ve come across is Backblaze. It has a .bzpkg file that grows with the number of files backed up.

5 Likes

I recommend DaisyDisk or Grand Perspective as great apps to find the culprits. Choose between those depending on your preference for the radial or grid display modes. I far prefer the grid in Grand Perspective. Both are available on the Mac App Store.

4 Likes

I was going to guess too Time Machine local snapshots that the system didn’t delete as it should.

4 Likes

As far as tracking down missing space, I recommend OmniDiskSweeper.

If the issue is Time Machine snapshots, then the easiest way to manage/delete them is Carbon Copy Cloner.

4 Likes

The latest version of Daisydisk can get rid of them too.

4 Likes

Thanks all - Daisy Disk works well doesn’t it?

image

image

It’s got rid of about 180GB for me!

I think I saw some CCC local backups in there, so I will investigate whether CCC can put things locally in unexpected places.

@ tjluoma How would I actually use CCC to manage/delete TM backups?

the “other” category filling up is usually APFS snapshots, which automatically get deleted if the disk gets too full.

As a long time mac user I guard my disk space carefully, but have found the latest OS versions to be very capable of managing the space for me. I still get nervous if I get anywhere near the 10% mark, but have never experienced issues. It usually cleans itself up in time.

I’ve very very leery of having Daisy Disk delete TimeMachine snapshots or anything else hidden. I did that once and the boot drive was messed up, which took hours to sort out.

My advice to the OP:

Trust Carbon Copy Cloner for this – don’t trust Daisy Disk. Or just do your TimeMachine backups and let macOS recoup the space as designed. If you don’t need that space, then it’s not worth being concerned about recoup empty space just to have empty space.

This has never been reliable for me.

A fair and reasonable question. Easier to show in a screenshot of CCC’s window:

Start by selecting the “Data” partition on your boot drive (mine is called “SSD” yours might be “Macintosh HD”)

Once you have done that, the right side of the window will show your snapshots.

1 Like

Doesn’t turning off Time Machine for a minute and then turning it on again delete all the local backups?

At any rate, what should happen with the local backups is that they get deleted automatically when the space is needed. So while you may get low on free space it should never drop to zero as long as there are local backups that can be deleted. YMMV of course!

2 Likes

Davey, I had a very similar problem, huge amounts of hard drive being occupied by ‘something’ I could not identify with any of the cleaning programs. I finally ran “Apple Diagnostics” and came up with an error message noting hardware issue and contacted Apple support, who ran a few more diagnostics remotely.

Apple identified the problem as my RAM having gone bad, with the Mac using the hard drive as virtual memory. I had a MBP with hard wired RAM and so had to buy a new laptop.

Find the Apple “Diagnose problems with your Mac” page and scroll down to “Use Apple Diagnostics” and try that (basically restarting Mac holding down the D key). You may also want to scroll down further to the “Use Apple Hardware Test” section and try that as well.

I share your frustration. It took a few months of my calling Apple, posting here, reading here, etc to solve. Hope yours has a happier ending than mine! Be well.

Let us know how it turns out!

2 Likes

From my experience it can also be stuff in your ~/Library folder. In my case once it was a huge After Effects cache that needed clearing I think. OmniDiskSweeper is good for jogging though your directories sorting by directory size to quickly isolate what’s taking up the largest amounts of space and drilling down til you find the culprit(s).

The console command to disable local snapshots (tmutil disablelocal) was removed in High Sierra or thereabouts.

There are a couple of command-line ways to wrangle them, which I suppose one could put in a corn job.

One, which I found on discussions.apple.com:

tmutil listlocalsnapshotdates / |grep 20|while read f; do tmutil deletelocalsnapshots $f; done

(The “grep 20” returns just the lines with a path to a local snapshot, which will all contain “20” as part of the timestamp)

The second is to use tmutil to tell the system, “Hey, I need 500 gigs of storage, pronto”:

tmutil thinlocalsnapshots / 500000000 4

(The options are tmutil thinlocalsnapshots mount_point [purge_amount] [urgency], where the amount is in kilobytes, and 4 is the most urgent on a scale of 1-4)

For details on how this works:

Thanks to this thread, I uncovered a problem I never would’ve figured out on my own. I just wanted to add in my thoughts for future strugglers.

My hard drive ran out of space out of nowhere. I had no idea what was going on. After reading this thread, I installed OmniDiskSweeper which uncovered a ton of space being taken up in my Library, specifically Application Support. After doing some digging, I found the problem.

I ended up deleting a ton of files but when I checked my Storage number in the Apple / About This Mac / Storage, the number was not updating. But once I shut down the computer and restarted, it showed the nice new number.

4 Likes

Glad to hear someone else has found OmniDiskSweeper useful. I still find it the most useful tool, even though it is probably the simplest. Some may even consider it “boring” but that’s fine with me.

2 Likes