What Markdown formatting is this?

I’ve been using a tool called YiNote to help me take time-stamped notes while watching YouTube videos. They have a Markdown export option, and I tried it today (I have usually done PDF in the past, but am trying to get more into Markdown,) pulled it into Marked 2 to try some styling, and it just came out like this:

When the raw Markdown text looks like this:

All the clickable links are lost, and a few other Markdown formatting items are not translated either – at least to my limited knowledge of how Markdown works.

Does YiNote just use a weird version of Markdown that’s not compatible with Marked 2 (or DEVONthink, I’ve tried it in there as well to no avail)? Does anyone have any insight into why this might be happening? Thank you for your help!

That’s HTML. the “p” and “/p” are paragraph tags. There is an “href” header at the top. Etc. Definitely not markdown.


I agree. The output in the second picture is HTML not markdown.


HTML indeed, with the links in comments…

1 Like

Thanks for the info! Sorry I’m a rookie at this stuff. I’ll send a bug report to the developer of the tool, because I’m most assuredly clicking “Markdown” when choosing an export format. Weird.

Thanks again!

1 Like

By the way, your text - as shown - should not really have much formatting to it, except for punctuation. Your screenshot did not appear to present with any formatting (bold, underline, footnotes), which means that it’s pretty clean. Your paragraphs simply carry over as paragraphs in Markdown.

I have attached a screenshot using an only converter.
I dictated your screenshot into text using Drafts. :slight_smile:

Thanks for the info! I’d like to retain the links, and “##” header tags to make things look a bit prettier, but that’s good to know.

1 Like

In addition to the comments above, the markdown links ([anchor text](https://...)) have been embedded in HTML comment tags: <!- ... ->

So, that’s why Marked 2 will not parse the links. The code is telling Marked to “ignore me”.

1 Like