Why can't I upgrade a 2015 iMac to Monterey? It's listed as being a compatible operating system

I picked up a used iMac 5k mid 2015. Apple’s website states that the latest compatible operating system is Monterey.

-Apple’s serial number lookup verifies the model, but it only let me upgrade it to Big Sur:

-I have plenty of disk space, so that isn’t the issue.

-I found that Monterey is no longer available in the App store, so I downloaded the installer from https://mrmacintosh.com/macos-12-monterey-full-installer-database-download-directly-from-apple/ which is apparently a well known source. I tried installing from within Big Sur and got the error message above.

-I made a bootable USB with the image from above, tried to upgrade that way, but got the :no_entry_sign: boot window, indicating the operating system was not compatible.

-The seller had performed a clean install when he gave it to me, and it was running Yosemite. I was able to upgrade to Big Sur from a download at MrMacintosh, but not to Monterey.

I’m at a loss. Why can’t I upgrade?

It says here…

… that Monterey is only compatible with the Late 2015 model of the 27-inch Mac, not the Mid 2015 one.

The information on the page from the screenshot is probably incorrect (as some Apple Discussion posts also conclude if you search a bit). You may want to try OCLP, though.

Ah, I was using Identify your iMac model - Apple Support which indeed is contradicting to the link you provided. I was hoping to avoid OCLP as I’ve always had graphical issues with other iMacs.

Thanks for resolving this.

Mactracker also reports that the Mid 2015 iMac supports up to Big Sur only so that’s apparently a mistake on Apple’s Identify your model page.

(I’d post an image from Mactracker, but there’s still an issue with posting images here.)

Welcome to the MPU forums, by the way!

That’s a bummer. I have a Late 2014 Mac mini that is running macOS Monterey 12.7.5