Why can't OmniFocus remember my password?

This has been a longstanding problem for me, on multiple computers and versions of MacOS.

OmniFocus regularly puts up this dialog box:

and I have to supply my sync password. Interestingly, it always requires this be done twice: after the first time I put in my password, the dialog comes up again and I have do the password a second time. After that, OF seems to work fine as long as I don’t let my computer sleep, but the next time I wake it, I have to do this again.

Has anyone else seen this? Is there something I should be doing differently?

I can obviously work around it easily, but it is annoying and I have to assume this is not the desired or intended behavior…


You’re definitely not the only one who’s had it. Try removing certain keychain items. Their support walks you through other steps if that doesn’t work.

Here’s a support doc with the keychain instructions. (They pointed em to this doc when I had the issue.) Resolving repeated "The server 'Omni Sync' requires authentication" prompts - Support - The Omni Group

1 Like

I get this when waking up my laptop. Thinks it’s a race condition. I just cancel the dialog box and manually sync. Never had to re-enter my password. Annoying but less so than having to look up the password in my password manager.

1 Like

Thank you!

Confusing that it would be a keychain issue in that it has happened on multiple Macs…I wonder if there is something in my setup to be causing it…

I will try removing the keychain entries and see what happens.

I ran into this problem a few years ago, and Omni’s help file solved it.

And then just a few weeks ago it started happening on my personal computer. I hadn’t had time to look up the relevant help documentation, so thanks!