WiFi QR code scanning

Somehow scanning the QR code for my Guest network is not working on any of mine or our guest iPhones.

I tried with two different services:

I triple checked the correct SSID and Password and tested with the Guest and my main network.

The camera box remains amber-colored.
Manual entry of the password works.

I made sure while testing that the WiFi network was removed from list of previous connections.

Before I waste hours on trying to figure this out. Anything I might have overlooked?

Matthew Cassinelli has a video My TOP 10 Shortcuts! Built working at Apple - YouTube which includes Make Wifi QR Code.

That worked fine for me when I tried it awhile ago.

Maybe try that?


I tested this on my home network just now and it worked for me. Be careful with auto-capitalization on iOS.

Thanks I will check it out. I created the QR code on my Mac and copy pasted the password

I’m with @MacExpert on this—something has changed. I have had a QR code for my guest network which has worked fine for a long time. Recently I had a client in my office and her iPhone couldn’t connect with the QR code, but manual entry of the pass phrase worked fine…

1 Like

I got it working again by adding the QR code reader to the control center.

Settings > Control Center: Enable Access Within Apps
Settings > Control Center > Customize Controls: At the QR code reader by selecting the green “+”

When using the QR code reader the process of joining the WiFi network is very intuitive.

Using the regular camera also prompted the “Join Network” but the box remained yellow and the message was at the top of the screen. This is not intuitive and will deter the average Guest user.

When I removed the QR code reader from the Control Center it still worked like before (less intuitive). Clearly toggling the QR code reader on/off triggered something in IOS to make it kind of work again.

I consider this a bug in iOS 13 and reported it via the developer program.

1 Like