504: The Release of macOS Catalina

3 Likes

We didn’t want to wait a week to talk about this, so we recorded a bonus episode to go along with my review of Catalina.

8 Likes

@ismh: Didn’t you want to stop this daily podcasts thing? :smile:

4 Likes

Just to reiterate something I read on a different thread: Hazel is not yet working well on Catalina:

3 Likes

What I really don’t like is that Apple pushes this UPGRADE as an UPDATE.
This is going to cause lots of trouble for people who are faithfully updating their Mac’s and accidentally upgrade to 10.15 with all its consequences.

This move is even worse then what Apple did with Mojave by pre downloading it in the App Store.

Not cool

4 Likes

My mac (Macbook Pro 13‘ mid-2014) hangs at the “configuring Mac” stage for 1 hour now. Any tips???

Same here. I did reboot it and everything is - apparently - OK. :confused:

jepp, did that as well now. Seems to work. Now I have a moved objects folder (flyttede objekter)on my desktop though. Anybody know what that is all about??

49

So it was important to myself and my husband that video playlists were still available. You cant create them in the iOS or tvOS Apple TV apps.

Fortunately the functionality is preserved in the library tab of the new TV app on macOS.

It’s a bizarre thing to say but our use case is literally a medical benefit, so we were looking at potentially having to preserve a Mojave Mac just for this.

Also, @MacSparky, the star system for media still exists (I’m 90% sure) but you have to enable it somewhere in preferences.

You will find a document and several folders inside of that symlinked folder.

The document explains to you what is going on. Basically, Catalina’s update process has detected some system files that allegedly have been altered by yourself or an application. As far as I understand the issue, those files could not be migrated/updated to Catalina. So, those files have been taken away from your system and they have been replaced with pristine ones. At least, that is how it sounded to me.

In order to browse the linked folders, you need sudo permissions. I decided that it is not worth the fuss: if Apple thinks that those files have been tampered with, they are garbage to me.

So, I deleted the symlinked folder (I do not remember the path) and I deleted the symlink (“folder”) on the desktop.

And yes, I have a Mojave clone backup… But, I am quite happy with Catalina so far. Accessing my NAS feels noticeably faster and I like it to use my AppleWatch to grant Admin privileges… That is even more convenient than TouchID. And it is definitely more convenient than entering a password. :slight_smile:

3 Likes

I took exactly the same view, and just deleted the folder.

1 Like

Do you remember where this folder was? I deleted the Alias on my desktop and was planning on getup around to finding the folder later… and well, you know, I forget where it is now!

Mine is gone. But according to https://www.reddit.com/r/mac/comments/cf6g7b/not_sure_what_to_do_with_this_folder_more_info_in/, it should be found at: Macintosh HD>Users>Shared>Relocated items.

Like I said, I cannot check, because I have deleted mine. But that sounds about right.

I ran into the same issue and ended up rebooting after 30+ minutes. Everything seems to be fine.

Funny (well not really): The new photos app presented me „your nicest birthdays“. It was almost exclusively pictures of my grandmothers funeral, which took place not even on my birthday but a few days before that some years ago. Must have looked like a glorious party to the AI, with all those different people in black ties.

Unfortunately voice control (and especially the dictation feature) seems not to be available in german yet. I hope this gets added, I’d love to use that.

3 Likes

That was it! Thanks !

Is anyone else missing their purchase history on the Mac App Store since upgrading? The store doesn’t seem to think I have any previous purchases.

I’ve tried signing out and back in with no luck, so I’m about to try a reboot.

I updated my Mac Book Pro 2018 to Catalina just now, until know everything is working fine, I had one app that needed updated, and that’s it. The only issue I see is that the messages are not syncing as I would expect, but I will give it a little more time and see what happens… beside that everything is working fine.

Well, my problem isn’t resolved. But I’m also not the only one, at least:

Purchases are missing (Apple forums)
Catalina has lost all my App Store purchases (Reddit)
Missing purchased apps from Catalina App Store (Reddit)

This is aggravating. I never had trouble with the betas, but I ran the betas on the old machine that I traded in a little over a week ago. Since I just got a warranty exchange on the new machine, which was stuck on reboot yesterday, I figured I might as well update it to Catalina right out of the box, then install my apps.

Apparently that was a mistake. Sigh. Otherwise, I really like Catalina. Everything else is working fine. (Heck, if I download something like OmniFocus, the system even recognizes my subscription. It’s just apps that have to be paid for up front that I don’t dare download.)

As usual, I think I’ll be waiting for the first dot release of Catalina before I make any moves to upgrade. I just don’t have time to waste on troubleshooting potential issues :grimacing:.

2 Likes