Apple Watch Mac unlock not working

Not sure how to describe the problem. Basically, I started noticing that my Apple-Watch-to-unlock-Mac wasn’t working. Even though I had disabled and reenabled it several times. Then I finally noticed something weird, when I was installing some app that needed the update to the System Preferences/Security and Privacy settings. Generally, what happens when I click the lock to unlock that area is that my watch vibrates, prompting me to unlock by clicking the watch button, but then also prompting me to touch the Touch ID button on my Mac. Generally, when faced with this choice, I always touch the Touch ID button because it’s faster since my hands are already right there on the keyboard.

However, on a whim, I decided to see if I could still opt for clicking the Apple Watch to unlock the Security and Privacy settings. I couldn’t, and here’s why — as soon as I click the Security and Privacy lock to unlock, the Apple Watch screen briefly shows the “double-click-to-approve” screen, but then it disappears within a half a second or so and doesn’t give me the option to click it.

I ASSUME this is some clue as to what is also happening with the unlock-Mac-with-Apple-Watch function? It possibly briefly triggers it but then stops short of execution?

Anyhow - this is all I got. If anyone has any ideas that would be great. Otherwise, I guess the Apple-Watch-to-unlock was nice while it lasted…

I gave up on Apple Watch unlock a long time ago. It was maddeningly sporadic and unreliable, looks like that hasn’t changed.


Are you running the Ventura beta?

I have found that ever since I got the Mac Studio, my watch needs to be quite close to it before it will work. I keep my Studio further away on the desk than when I used a MacBook Pro, and if I want it to unlock reliably, my left hand (with the watch) needs to be at the keyboard and not resting on my lap. (My Studio is at the back of the desk, to the right.) Sometimes I even move it closer, which is awkward, but it seems to make it very reliable.

Also, I seem to recall that when Apple first released the feature, the watch would unlock the Mac if I was even further away. For example, if I was working at my other desk and the Mac was asleep, one of the cats would walk across the keyboard to wake up the Mac, and it would unlock. My other desk is only about 4 feet away. Later, that stopped happening and I had to be sitting quite close for watch unlock to trigger successfully.

It makes me wonder if they tightened the radius for watch unlock? And maybe you’re at the edge of it? Something to consider.

My Watch is doing exactly the same, but only if the „Sleep“-Focus has activated the „Before Bedtime Function“!
Maybe there is relationship to your problem too?

No – am on Monterey 12.4 and haven’t tried Ventura.

1 Like

Interesting @margaretamartin - I tried holding it close and it didn’t seem to make a difference. But I’ll keep an eye out on that variable, especially after setting/resetting/rebooting.

@Ulli I do have that turned on as a matter of fact. Turned it off and it didn’t seem to make a difference…

I am going with the @jcarucci theory at this point – that function just seems buggy and/or prone to getting fouled up by different idiosyncratic variables that shouldn’t foul it up.

Yes, if I turn it of, I also have to sign out and back into the Mac, to have it working.

For me, Apple Watch unlock of my Mac and iPhone is mostly consistent. Which is to say, it consistently works when I’m not expecting it, and consistently fails when I actually want it.

Actually, on my phone it’s about 50/50 whether it will unlock when I’m wearing a mask — the only time I need it — and also 50/50 that it will unlock when I am not even attempting to unlock. Taking my phone out of my pocket to put it on a desk, or removing it from the holder in the car to put into my pocket, about half the time — bip-bip — the haptics at least warn me it’s unlocked.

On my Mac I never want it but about 20% of the time it beats me to unlock the Mac before I reach the Touch ID sensor. I should just turn it off.

It’s strange this is so inconsistent.
I use it to unlock my iMac Pro and my M1 MBP, and it consistently works well for me.

This might be worth a shot (caveat emptor):


User level:Level 1

(13 points)

Nov 12, 2021 5:23 AM in response to wforan3

I managed to fix this issue without repairing my watch. Steps were:

  • Open settings, privacy & security, general and uncheck open with apple watch.
  • Open Keychain Access, under View menu make sure ‘show hidden items’ is enabled.
  • Search for ‘auto unlock’ select all the auto unlock entries, right click and delete them.
  • Search for ‘autounlock’ select all the autounlock entries, right click and delete them (some will instantly reappear).
  • Restarted Mac.
  • Open settings, privacy & security, general - then make sure your apple watch is unlocked and your iphone is unlocked and both near the mac. Then check open with apple watch.


@JohnAtl Just did the steps. Had a brief scare where my Mac couldn’t communicate with the Apple Watch. But then after trying again it seems to be working! For the moment…

@JohnAtl - I will say, it was interesting to see how many stray Auto Unlock entries there were from prior years… Could see how that might get things a bit funkified…

I followed the instructions and now I’m having the same problem but it is not resolving itself. :frowning: I’ll continue trying …

@Bmosbacker sorry. Don’t remember what I did to resolve. Exit out of system preferences and open again? I don’t think I rebooted but I could have.

I finally got it working again. It took a couple of reboots but it is now working. I was surprised by how many auto unlock Files there were in keychain and in the library!

1 Like

Update – my new Apple Watch settings did not survive the night. Not working this morning. Anyone else?