Arq Backup 6 released

Arq 5 has been happily chugging away for me for the past couple of weeks, backing up to MinIO running on my Synology. (And partially responsible for my starting to warm up to Synology again.)

Today, Verizon 6 of Arq Backjp was released with lots of nice features, such as support for APFS snapshots, parallel backup jobs, auto mounting networks shares, etc. etc.

More info on their website

Edit: I haven’t tried version 6 yet.


Yes, they invited beta testers recently. I did not offer my help because I wanted a smooth migration (backups are too important to mess with).

Unfortunately I did not get that:

  • Arq v6 is per machine, while Arq v5 was per user and now I can’t activate Arq on my second and third machine with my lifetime license (which the developer confirmed as a bug; we should be able to activate on 5 machines). Current workaround: use the 31 day trial.
  • The Windows version could not import my existing (200+ GB) backup and does not even start after I rebooted the PC (some Specified cast is not valid error). This means I cannot make additional backups nor restore any existing files until a new version with a fix is released. No workaround?

Oh, @JohnAtl which option did you choose when migrating existing backups?

I chose the “slow” option that converts all snapshots to the new data format. For one backup set that took 2.5 hours and for another 5.5 hours. Those are my small backups… The big one is on the Windows PC that I can’t access now. I’m curious how long this takes for others.

But anyway, I’m glad I did not have to re-upload all data on my Macs. Hope that will turn out true for the Windows PC (still my main machine) as well!

Oh, different question altogether:

What’s a good list of files/folders (caches) to exclude from backing up?

In addition to making the licenses per machine, it looks like they got rid of the lifetime purchase option. I hope they still honor those that bought lifetime previously.

1 Like

There’s at least an upgrade price ($25 for me). Not clear at all from their website. But it shows when you buy a license and enter your e-mail address used for a previous registration.

@JohnAtl Thanks for mentioning. I didn’t recieve mail from Arq, nor did this new version show up on MacUpdate.

Apparently there is a bug where people with lifetime updates are being asked to purchase the upgrade. From what I saw on reddit, people are using the trial version until this bug is corrected.

TL;DR lifetime is still lifetime

Damn! It appears I have a lifetime license. But paid for the upgrade. :frowning:

Guess I’ll have to send them an e-mail.

Same here. Looks like they are swamped. Not surprising since the documentation page is 404.

Upgrade was uneventful. Lots of changes: exclusions are manual entries, no select from GUI. And I’ve yet to discover how to pause backups.

But a small restore from a few months ago was successful so no worries so far. I’m going to wait until things settle down before I ask about lifetime licenses.

Did you install v6 on top of v5? Did the installation retain all the configuration? I’ve used v5 to backup to B2 for years, and do not want to lose the prior configurations in Arq v5.

Yep that’s exactly why I’ll hold off and wait till things settle.

1 Like

I also bought Arq 6 as an upgrade for $ 29.99 as a family pack for up to 5 machines. Really good price for something my family and I are using for years.

The “slow” import of 1874 snapshots from my NAS took 6h. 651 snapshots from Wasabi took nearly 2h.

Can it be that lifetime means lifetime of the version… so all updates for version 5 are included?

1 Like

Yes. I selected the “Slow” installation which imports all the snapshots. With the exception of the two things I mentioned everything appears to be there. But it takes some digging around to find things.
Also, get used to entering your encryption password. Changes now require it.

1 Like

Lifetime means lifetime. I entered my Arq 5 license in Arq 6 and it got accepted. That’s after I removed the Arq 6 license code I bought.

Not surprised that their support got swamped. It’ s not a pretty upgrade. The UI is a bit messy to say the least, And I tried to import my old config, but have no clue what happened. But no (proper) import, that’s for sure.
In the end I decided to create a new backup. That’s fine with me. However, I’m now looking at a spinning wheel and the word “Saving” for more than 10 minutes now. Guess that’s not okay.

Should have stayed with Arq 5 as there was nothing wrong with that application. Arq 6 is beta, at best.

Mind you, I know y way around S3 and am an Arq user since Arq 2.

That has been solved now, they told me.

I could indeed activate Arq v6 on my Mac mini using the same Arq v5 Lifetime license I used to activate Arq v6 on my MacBook Pro. I can’t also try it on my Windows PC though, as the GUI does still not finish loading there… (I’m in contact with support but they have no clue yet on what’s going on).

To make things worse Arq v6 stopped working on my MacBook Pro. Well to be precise, maybe I wished it did… Its agent is now using 200% CPU after every reboot, while the backup remains at 0%…

It’s a pretty bad upgrade, isn’t it?

1 Like

For me the experience has obviously not been good so far. I hope they can improve.

Was hoping to catch up on details to see whether I could help, but documentation is not available yet?


Ugh. I’m sticking with v5. Plunked the money down for the upgrade, but my B2 data are worth far more than some two-bit upgrade process that might break.

1 Like

Like others, also waiting to upgrade until the dust settles.

I couldn’t see how version 6 was going to make a difference for me anyway.

That’s (part of) the problem. Developers keep on changing software that’s working perfectly fine for most of the users.
Of course, innovation is good. But sometimes it seems changes are made for changes sake. Like the new UI in Arq 6 for example. Users (in general) don’t want change. They want stability.

1 Like