Bizarre MBP WIfi Problem Round II

WiFi Madness

A new version of my old problem? Or a new problem? Bizarre MBP WiFi connection problem

Last time we played this game, Bell upgraded our Modem to a Giga Hub. Firmware version 1.19.6. This modem seems to have solved the ppp0:TR069 errors we had in the past. Fantastic.

Now I have a new (or renewed), problem. This one is stranger than the past.

Background for the past month, I’ve had rock solid WiFi anywhere in the house.

Starting on Monday this week, my M3 MBP 14" (MacOS 14.4.0 and 14.4.1) won’t access the Internet over WiFi in my office. If I move anywhere else in the house it works. When I’m in my office, it remains connected to the WiFi but says the router doesn’t have access to the internet. Yet I can I use my iPhone and iPad over Wifi in my office with no trouble.

Things I have tried:

  • Move down to the main floor and my internet fixes itself almost instantly
  • Reboot the Mac
  • Update to MacOS 14.4.1
  • Reboot the modem
  • Delete and recreate the WiFi connection
  • Plug/unplug from my OWC Dock
  • Power off/on the OWC Dock
  • Power off the power bar under my desk (powers monitor, dock, etc)

Cast tea leaves - that didn’t work either but I got a nice cup of tea.

Basically within a few seconds of entering my office, my WiFi will flip to the ! state (connected to WiFi but not internet).

I have had strange LAN/Internet problems and have found the best tool for trouble shooting problems is “iNet Network scanner” (The iNet Network Scanner and Toolbox for Mac). Particularly useful is the “Scan Settings:” which shows all of your network interfaces including Ethernet, WiFi, and Thunderbolt ports. Also you didn’t mention re-booting the Router?

Thanks I will look at the tool.

In this case the router and modem are a package deal. When things work well, I’m happy with that.

After I posted this, I realized that my MBP is the only WiFi 6E device in the house. Since disabling 6E for this connection things have worked better, with no speed loss.

Also for fun, I think the modem logs:
A WiFi device <MarksInbatorMBP [60:3E:5F:34:0D:39]> was disconnected on SSID (BellandLevison)[RADIO5G]
A WiFi device <MarksInbatorMBP [60:3E:5F:34:0D:39]> has successfully connected to SSID (BellandLevison)[RADIO6G]
A WiFi device <MarksInbatorMBP [60:3E:5F:34:0D:39]> was disconnected on SSID (BellandLevison)[RADIO6G]
A WiFi device <MarksInbatorMBP [60:3E:5F:34:0D:39]> has successfully connected to SSID (BellandLevison)[RADIO6G]

…hint at a problem connecting/disconnectiong to the 6G/5G modems.

So I can’t yet tell. Is it an Apple problem not having done 6E well? or does the GigaHub have a bug?

Are you using ipV6? If not, Mine is set Link-Local Only

Are you “adjusting” your WiFi? Channel, Signal width, etc., etc.

Don’t start tuning for performance until your connection is stable.

1 Like

I never tune my modem anymore. The more I change non default settings the harder it is to remember why I picked a combination.

IPv6 - I’m setting an option for it at all on the web interface.

How far away are you from the WiFi Access Point?
Are there any obstacles like thick walls, furniture, appliances or large mirrors in between?

20-25 feet and one floor, maybe less. No appliances. My office and modem/router have been in their respective places for years. Never before a problem,

The modem/router is new: early Feb and even since then no problems. The first problems showed on Mon Mar 25, at 9:30 am at the start of a workshop. Timing is everything.

I’m guessing that was around the time of the MacOS 14.4 update.

In anycase by turning off WiFi 6E for this connection, I’ve avoided the problem.

1 Like