Calendar Crashes on High Sierra

icloud
calendar

#1

On my Main iMac the Calendar app now crashes on start constantly. It worked fine for a few hours when I first did the update to High Sierra but started crashing a lot yesterday and now I cannot get it to run at all. It hangs on “Updating calendars”

I’ve deleted all 4 cache files, rebooted, even restored from time machine to just after I did the upgrade when it was still working and still can’t get it running.

I do not use iCloud for calendars so there is no option to go there for a backup. My phone has the accurate calendar up to Sunday, when I last backed it up. I do not use wifi backup on the phone.

I was thinking of trying to sync the phone but since that is the only good calendar and there is no option in iTunes to tell the system to erase the Mac version and use the one from the phone I am leery of doing it.

Other suggestions?


#2

So why are you using Calendar on the Mac? What are you using it for? Or did you just launch it at random and notice it crashes?

First look in System Preferences to guaranty that iCloud calendar syncing is indeed turned off. Why? Because in order for the Calendar to be ‘Updating Calendars’ it must be somehow trying to sync.

Try turning off Wi-Fi before launching Calendar on the iMac. Without a network connection the app may not try to update, and therefore might not try to sync (or immediately stop), which might give you time to take a better look at the data to see if its corrupt.

I’d have other suggestions if you wanted to use Calendars on the iMac and wanted to sync data over from the iPhone, but you don’t seem to want to do that at this time…


#3

I use calendar all the time to track what I did. It’s also how I track hours at various tasks. It’s usually running the entire time I have my machine up. I actually have a bunch of calendars, one for farm work, phone, desk, computer, LambTracker and more.

I publish my calendars to our Synology NAS but don’t pull them from there. I send from the mac to the Synology. I do not subscribe to other calendars

Yes, Calendar sync is off in Internet accounts and i cloud preferences in system preferences.

I have both wired and wireless connections for network access, will go test that next.

I wouldn’t mind taking the data from my phone and putting it on the mac but not sure how to do that and avoid corrupting the only valid calendar set I have.

Edited to add, however, the only data in the phone is back 5-6 months or so. My mac had data going back years and yes, I do use and search through it regularly. I thought the regular backups would be enough to recover.


#4

Update: Tried after turningoff all networks and still crashed with same error message.


#5

If you use iCloud calendar sync with the iPhone, iPhone will upload the calendar and the iCloud version becomes the canonical one. You can then turn on iCloud calendar syncing on the Mac and sync back down to the Mac. And Mac calendar data would likewise go to the cloud and be canonical.

This of course all assumes the Mac app is working properly, which it isn’t.

Do you have any recent Calendar backup files (via Export > Calendar Archive)?


#6

Latest update. So… I never use calendar on my laptop. Booted it and verified that the app is working properly there.

Then I moved a copy of the entire Calendar folder from within Library on my iMac and replaced the calendar folder on the laptop. Risky but at this point WTH.

Booted up calendar on laptop and it’s working and all data there. Made a backup ASAP by exporting a Calendar archive, so yes, I now have a current backup

Agreed now that the Calendar app is hosed on my main machine.

Thinking my next move is to try to reinstall the calendar app? Only way I can see to do that is to reinstall High Sierra? Or am I missing something else.

I suppose I could copy the app from laptop Application folder over to the iMac and see what happens…


#7

• Yes, unfortunately Apple won’t let you separately download Calendar from the MAS - you need to do an OS install, which does seem odd.

• On the Mac is it possible to launch and quickly uncheck all calendars so they don’t get shown/accessed/updated? If so, maybe you can forestall the crashing, delete the offending calendars, then reimport them.

• Another option: export your calendars to Google Calendar. Many years ago I had major problems with Apple Calendar eating and duplicating events (at this point I don’t remember if it involved the app specifically, or iCloud, or what) and I migrated to GC, where I’ve been happily living ever since. And you can easily subscribe to GC feeds in iOS for any calendar app (I use Readdle Calendars5, which logs in directly), as well as any calendar on the Mac (including Apple Calendar, if it’s not crashing!).


#8

You can create a new user, then see if Calendar runs. If so, the app isn’t corrupt.

Details about moving files from Library folders, etc. to troubleshoot can be found. E.g.
https://discussions.apple.com/thread/7437935


#9

nope I never see the calendars come up on main mac, it just crashes when updating.

not an option to move to google. We do not put that sort of data in a cloud service.

Tried on another non admin user and the app appears to come up but I didn’t do an extensive test

I had already tried the removal of the cache files and it didn’t help.

Also as above, moving the entire calendar folder over to a different mac and it does come up and run properly.


#10

One workaround is to create a 2nd administrator user account, then import the calendar data. That should work.

If it does, then just move over all your files to the new account and nuke the old one.


#11

Also, did you go into System Preferences > Internet Accounts and make sure iCloud doesn’t connect to Calendars? and that there’s no other calendars (eg Google, Yahoo!, Outlook) in the leftmost pane (which would involve ‘updating’).

And did you go into System Preferences > iCloud and make sure that Calendars is not checked?

And that System Preferences > Extensions does not have the Calendar widget enabled in the Notification Center?

And did you check to see in System Preferences > Security & Provacy > Calendars what if any apps have permission to access calendars (and did you try unchecking all)?


#12

Finally, here’s another workaround I found from someone who had the same issue as you.

> Not a Fix, but a workaround:
_ _
> I had this same problem going from Sierra to High Sierra (10.13.2). The Calendar app would start and crash as it was “updating calendars”. To test that it was my old data causing the issue I created a folder in ~Library/Calendar and dropped all the contents of ~Library/Calendar into it (essentially hiding all the previous data). I then launched the calendar app and viola, it started just fine, but empty. It did load my CalDev account I have on my Synology. Instead of spending more time fiddling with my old calendar data, I just let it rebuild itself from the Synology. I assume it will do the same if you have a copy of your calendar synced with your own local server or a cloud.


#13

OK I’ll try to answer all questions here and let you know the current status.

After verifying that I could move the calendar folder to a different machine and it worked I moved it BACK over the top of my main mac calendar folder.

It comes up and appeared to run properly. Until this morning, Now it comes up, I can see the data but as soon as I try to add an event it crashes. If I try to copy an event it crashes but when I go back in the duplicate event is there. If I move an event using the mouse to drag it into position it crashes. If I try to add an event it crashes but when I re-open the event is there with the edit bubble still popped out.

I did verify nothing in Internet accounts icloud, no other calendars, no notifications, only app with access is TimeTable 3 which I use to track the hours doing stuff for the non-profits I do work for.

All my calendars are being published to our Synology server. They are all set to automatically update changes. No reminders, alerts or attachments are being published.


#14

Playing whack a mole here now…

Formerly working installation on my laptop went tits up this morning and is now crashing all the time upon open same error message as the main mac had, dies on updating calendars.

Partially working installation on my main mac now crashes whenever I move, add, duplicate, delete or edit any event in any calendar. The changes do get made but it’s impossible to really use it with the constant crashing.

I’m at my wits end here.


#15

Have you tried using an alternative Mac calendaring app that accesses and edits Apple Calendar data? If not, Fantastical has a free 3-week trial and BusyCal has a free 30-day trial.

If you have trouble with those apps then you most likely have serious file corruption of some kind, which might be difficult to single out and exclude.

I don’t think you can upload your calendar data straight to Apple Calendar in iCloud, but if you have it working on another machine you could turn on iCloud calendar sync, get it canonically in the cloud (and accessible via icloud.com, and iOS devices).

But I really think you should take my earlier advice and create a new administrator account on the iMac, and import your calendar archive to it. Play with it there, and if everything works simply migrate your other account files to the new account and nuke the old one. Simpler and quicker than reinstalling macOS.


#16

OK latest updates

Downloaded BusyCal and tried to bring it up. It came up but then said it didn’t support the publication onto the server and stopped the import.

Created a new Admin user, moved the backup to there and tried it. Same failure mode as on my main admin user, crashes whenever I move, add delete, duplicate, edit etc. an event.

Connected iPhone to mac, ran iTunes and synced. Got the latest down to the phone. That appears to be working as long as calendar is not up when I sync the phone. I don’t do wifi sync, only via cable.

On main mac bring up calendar and verify that everything is still there. Even the events that it crashes on when I created them or updated or copied are there in the main mac.

Created another backup. They are all time stamped so I have a running file of them.

Then, on a whim, decided to unpublish all my calendars. My husband is the only one who was planning on subscribing and he’s been busy with other stuff and hasn’t done it yet so nothing lost. Unpublish gives the warning that the data will be deleted off the server. At this point it us unlikely to get much worse so WTF. I first did a test on 1 calendar, unpublished it, then tried to duplicate and move, then edit and add events in that calendar. And it all worked!

So I quickly unpublished all 16 calendars and am making a backup now.

If that works I’ll run for a few days that way and then re-attempt the whole how to share calendars with my husband without using any 3rd party cloud services. Otherwise I’ll just keep what I am doing, he hands me his apts. on paper or tells me and I add them to my calendar and remind him of them. We’ve tried keeping 2 calendars but that never works as one or the other would book something at the same time.


#17

Sounds like it’s corruption of a system file but I have to idea where to check. If there’s nothing with permission to access your calendar in System Preferences > Security & Privacy > Calendars then you might need to reinstall the OS, as Calendar cannot be reinstalled by itself (without pulling it out of an install package and probably applying some additional Treminal-based mojo beyond my ken).

If you can upgrade to Mojave I’d recommend it. Current version fixes a lot of issues all over the place, and this issue might go away with an update, if only by flushing caches/plist files you haven’t or don’t know about.


#18

As I said NO CLOUD other than my own. Not an option for reasons I will not go into but just NO.

So today’s update. I unpublished all my calendars from Synology, but upon reboot found they were coming back up as published. Stopped the caldav service on synology and did a forced sync to both iPad and iPhone overwriting calendars on the device with ones on the mac.

Seems the issue now is I can’t get the unpublish to stick.

Have gone through all accounts and services and cannot find ANYTHING that is still talking to calendar at all so again, baffled.

As long as the calendar is not publishing then it works.


#19

I’m really sorry to hear about your calendar problems. After reading through the various things you have tried so far, I have two thoughts just off the top of my head. (I don’t know if you have tried these things yet or not.)

  1. Have you tried starting with a fresh preferences file? Maybe the current calendar preferences are corrupted and this is why the calendars will not remain unpublished. (Before launching Calendar, move its plist file out of your home folder’s Library/Preferences/ folder. Then launch Calendar, let it create a new preference file, and unpublish the calendars if they aren’t already unpunished.)

  2. Have you checked the Synology web site to see if there is a patch or OS update which has better compatibility with High Sierra? Perhaps there was a known issue with calendar sync/publishing between certain versions of the Synology software and Calendar in High Sierra. Hopefully there is a support article with the steps to take and/or the Synology software update to apply which will get things running like you had them before.

Just a thought!


#20

Yes, every time I’ve deleted the cache files I also deleted the .plist file

Yes the synology had an update, which we applied but it dod not help.

Every time I start calendar it boots with all calendars published.

If I try do anything with events while the calendar is published it crashes. If I unpublish a calendar I can then edit, move and do anything to events in that calendar.

I logged into my icloud account via browser and all the calendar names show up in there but with no data. I cannot delete any from iCloud because I get an error message that I have to have at least 1 owned calendar. I have never added calendars to iCloud knowingly so I have no idea how it even knows what calendars I have on any device. The only thing I sync in iCloud is Safari bookmarks.

I’ve just gone and turned even that off to see if that helps at all.