Disappearing Share Sheet Apps on iOS 14

Okay, this is a weird one and I don’t even know where I’d begin to troubleshoot it. I recently noticed that the DuckDuckGo app has disappeared from my iPhone’s share sheet (including in the More… menu), I asked on Twitter if they had removed it and while they never replied someone else confirmed it’s still there in the latest update on their phone.

Annoying but I mainly use it to get around paywall limits so not the end of the world to just copy and paste URLs.

Then DEVONthink disappeared on me and that I can’t live without because I use that a dozen times a day. I’m sure I could build a shortcut to do the same thing if I had to but I’d much rather keep using it the way I always have and if I’m missing two apps now what else will vanish on me?

Has anyone else run into this or have any ideas? I’d really rather not have to reset and restore and hope that works if I don’t have to. Resetting and starting from scratch would be even worse.

I’ve tried:

  • Restarting the iPhone.
  • Reinstalling the apps.


  • iOS 14.3
  • iPhone 11 Pro Max
  • DEVONthink To Go 2.7.9
  • DuckDuckGo 7.61.8

I’ve noticed that apps on the share sheet appear to be site specific.

Apps will be available when I’m using site 1, be missing a few minutes later when I’m on site2, and be back on site 3 a few minutes later. I suspect it’s the same reason some sites allow Reader View and others do not.

I’ve noticed this and heard a rumor it’s a known iOS bug. Drives me crazy.

Sometimes switching to the app directly restores the sharesheet extension to its previous position. I hear that restarting the device will fix the problem, though I have never tried.

1 Like

I think the share sheet is busted for a lot of us.
There’s several similar topics, all boiling down to the same thing: mysterious app disappearances

Seems there’s weirdness in sharesheet-land

1 Like

I notice I am quoted there but I had not equated that issue and this, but I guess it is.

More closely allied to this thread I noticed a few days ago that I could no longer share links to Tweetbot. I had not looked into whether any new versions may have introduced the problem and then yesterday it was there. No idea if I was sharing from the same app though.

I was not able to share at all to OF. Had to send OF an email. Very weird.

1 Like

I’ve seen it in “open in” and share-sheet items across both iOS and iPadOS, seems that mechanism is buggy since iOS 14

1 Like

I have this problem randomly with OmniFocus. I go to share something into OF and it’s not there. I close it and reopen it and it’s there. It drove me insane until I figured out that I wasn’t losing my mind.

1 Like

Share sheet is a broken mess. It should work on Discourse when pressing the “share a link” button, but it doesn’t.

1 Like

Share sheet has been broken ever since iOS11(?) when they changed it to its current layout. I liked the old one much better.

Dang, it sounds like it’s just really buggy and I’ve been lucky having not run into it before now.

So after seeing lots of suggestions to restart I tried it again for a third time and this time both apps magically showed back up. I really haven’t seen any other suggestions and I have no idea why it’s inconsistent but that’s so annoying, I hope they fix this.

Thanks all for the input, sorry I missed earlier relevant threads, I had done some searching but apparently used the wrong keywords here.

I actually prefer the UI better now, it feels less ambiguous though not every developer does it consistently. But I agree, bugs like this are a big problem.

1 Like

I have had this problem twice now with DEVONThink To Go. Each morning as I read the news I put interesting articles into DTTG — my “read it later” approach. One morning it just disappeared. Nothing I did got it back — other that shutting down the phone and restarting it. It happened again this week. Had to restart to get it back.

Happens to me frequently with Instapaper and with Pushpin (pinboard app). It’s almost always there the second time if I close the share sheet and reopen it.

I did see specifically a couple of people reporting the same issue right now on the DEVONthink Discourse, I wonder if some apps are more prone to it than others and a recent DTTG version made it less stable. :woman_shrugging:t3:

1 Like

I had that happen with Things and my iPhone.

Just as stealthily as it disappeared not long afterwards it just reappeared!

Slack disappeared about a week ago. Eventually it showed back up. Not sure what I did in the interim to fix it.