Discourse app login issues

Anyone else having issues logging in with google on iOS? I click on login with google and it takes me through authentication but then it just loads at the home page without logging me in. Have the same issue on multiple forums in the discourse app. iOS 12 on iPhone X

It’s an iOS 12/Discourse app bug. If you sign up outside of the app and then go back to the app to authenticate as login it should work.

1 Like

I tried that as well but good to know it’s a bug and not on my end

Is there a way to login outside the app? I was looking, but couldn’t locate it.

Login through chrome works but not safari or the app. On iOS 12

Can you post a login link since I’m not seeing an option to login on any browser including Chrome?

Here’s where it is when I have a fresh browser session on my iPad.


I was actually looking for the Automators one since that is the one Discourse isn’t allowing me to connect to through the app.

Do you have any ad blockers installed? They may be interfering.

I tried it with blockers off, didn’t browsers, and even on my iPad and I still can’t connect to Automators in Discourse.

@joebuhlig have you ever come across this before?

I can’t say I’ve heard of any issues seeing the Login buttons. If it helps, here’s a link to login. https://talk.macpowerusers.com/login

I personally don’t use those single-sign-on processes unless I have to. But I also can’t say I’ve heard of issues with those and the app. So I’m not sure I’m much help here.

The only recommendation I would have to try is to attempt a log in in Safari with your email, but choose Forgot Password. Set a new password and then use that method to log in.

Sorry I don’t have a better answer in this case.

For MPU, I’m good. I’m having issues with the Automators Discourse group.

I logged out and now I can’t log back in with the Discourse app. I’m going to delete the app and redownload it.

Nope! Can’t log back into MPUwith Discourse app.

Step by step exac what are you inputing.

Messages saying it’s not working are not working.

The app works fine on my iPad… But that not helpful in diagnosing your difficulties.

After pressing the login button, the login box comes up and I try to login with my Facebook credentials (probably should have made a separate account, but I was in too much of a hurry to join the fun on Discourse). Every time I try logging in, it keeps on coming back to this. image

I have been able to get back into Discourse through Safari for MPU and have been able to log into Automators, but it just doesn’t work through the app on my phone or iPad. If it was just the phone, I would suspect it could be the iOS 12 beta, but I don’t have the beta on my iPad.

@RosemaryOrchard, I was just able to join Automators through the Discourse app on my iPad. Technology.:man_shrugging:

1 Like

Very weird. I’ve been unable to replicate the issue at all, so I’ll add to your “Technology, :woman_shrugging:”!